1

I've consulted the spec https://www.ietf.org/rfc/rfc2328.txt and have googled to the end of the internet but I'm confused on OSPF Point-To-Point.

If I have the following:

  Link State ID: 4.4.4.4
  Advertising Router: 4.4.4.4

And then in my Router-LSA Update I have the following:

 (Link ID) Neighboring Router ID: 2.2.2.2
 (Link Data) Router Interface address: 10.0.1.1
 Number of TOS metrics: 0
 TOS 0 Metrics: 64

I know this means that OSPF Router 4.4.4.4 has a point-to-point connection to 2.2.2.2 via the interface 10.0.1.1 However, my question is as follows: Does the 10.0.1.1. interface reside on the 4.4.4.4 router or the 2.2.2.2 router?

2

What you are seeing is the neighbor Router ID and interface IP address. This is explained in the RFC on pages 12 and 13, particularly the point-to-point link of figure 1a:

                                              **FROM**

                                       *      |RT1|RT2|
            +---+Ia    +---+           *   ------------
            |RT1|------|RT2|           T   RT1|   | X |
            +---+    Ib+---+           O   RT2| X |   |
                                       *    Ia|   | X |
                                       *    Ib| X |   |

                 Physical point-to-point networks

A router will know its own interface IP addresses, but it needs to know the interface IP address of its neighbor. If it knows the interface IP address of its neighbor, then it knows which interface to use to reach that neighbor.

| improve this answer | |
0

This is the IP address on router 4.4.4.4, the advertising router

With OSPF P2P links, you should see two links for each P2P adjacent router within the router LSA.

The first link is of link type P2P with a Link ID of the other router's router ID (2.2.2.2) and Link Data should be the IP address of the advertising router on the adjacent subnet (10.0.1.1)

You will also see a second link, which is a Stub Network link to the subnet on the adjacent interface. This will have a link ID of the network (not sure but could be 10.0.1.0 in this case) and Link Data will contain the subnet mask (255.255.255.0?)

This is all in the RFC 2328 page 129

This may seem confusing as you would expect the IP address to be that of the adjacent router. This information is not needed when calculating the SPF as OSPF only needs to see a connection to the other router and any onward networks reachable by that router. When the router needs to actually forward a packet to an adjacent router it uses the neighbor IP address's associated MAC address to forward the packet onwards. This IP address can be seen using show ip ospf neighbor on a Cisco router.

Set this up in the lab:

R1:

interface GigabitEthernet0/0
 ip address 10.0.1.1 255.255.255.252
 ip ospf network point-to-point

 router ospf 1
  router-id 4.4.4.4
  network 10.0.0.0 0.255.255.255 area 0


R2:

interface GigabitEthernet0/1
 ip address 10.0.1.2 255.255.255.252
 ip ospf network point-to-point

router ospf 1
 router-id 2.2.2.2
 network 10.0.0.0 0.255.255.255 area 0


R1#sh ip ospf data router self-originate 

            OSPF Router with ID (4.4.4.4) (Process ID 1)

        Router Link States (Area 0)

  LS age: 66
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 4.4.4.4
  Advertising Router: 4.4.4.4
  LS Seq Number: 80000004
  Checksum: 0x865D
  Length: 48
  Number of Links: 2

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 2.2.2.2
     (Link Data) Router Interface address: 10.0.1.1
      Number of MTID metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 10.0.1.0
     (Link Data) Network Mask: 255.255.255.252
      Number of MTID metrics: 0
       TOS 0 Metrics: 1


R2#sh ip ospf data router self-originate 

            OSPF Router with ID (2.2.2.2) (Process ID 1)

        Router Link States (Area 0)

  LS age: 105
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 2.2.2.2
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000004
  Checksum: 0x7179
  Length: 48
  Number of Links: 2

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 4.4.4.4
     (Link Data) Router Interface address: 10.0.1.2
      Number of MTID metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 10.0.1.0
     (Link Data) Network Mask: 255.255.255.252
      Number of MTID metrics: 0
       TOS 0 Metrics: 1
| improve this answer | |
  • "...it uses the neighbor IP address's associated MAC address to forward the packet onwards [sic]." Unfortunately, that isn't true. In many cases of a point-to-point link, the interface protocol doesn't use MAC addresses. – Ron Maupin Aug 23 '16 at 15:26
  • True, was assuming Ethernet – Karl Billington Aug 23 '16 at 15:33
  • By default, ethernet is a broadcast medium, and it must be specifically configured to be point-to-point for OSPF. – Ron Maupin Aug 23 '16 at 15:35
  • That is correct, but many people do it, see RFC 5309 – Karl Billington Aug 23 '16 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.