1

Can someone freaking explain this to me? It's driving me NUTS.

Current running config:

vpdn-group 1
 ! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 2
 l2tp tunnel timeout no-session 15

Super Cool! Except that last command doesn't EXIST!

2901_easton(config-vpdn)#l2tp ?
% Unrecognized command

Here is the "?" for the entire thing...

2901_easton(config-vpdn)#?
VPDN group configuration commands:
  accept-dialin...................VPDN accept-dialin group configuration
  default.........................Set a command to its defaults
  description.....................Description for this VPDN group
  dsl-line-info-forwarding........Forward DSL Line Info attributes
  exit............................Exit from VPDN group configuration mode   force-local-chap..............Force a CHAP challenge to be instigated locally
  ip..............................IP settings for tunnel
  lcp.............................LCP specific commands
  local...........................Local information
  no..............................Negate a command or set its defaults
  pptp ...........................PPTP specific commands
  redirect........................Call redirection options
  request-dialout.................VPDN request-dialout group configuration
  session-limit...................Maximum sessions allowed for this group
  source..........................Configuration source for this vpdn-group
  source-ip.......................Set source IP address for this vpdn-group
  terminate-from..................Terminate tunnel from remote peer
  vpn.............................VPN ID/VRF name

Thoughts anyone?? I would REALLY like to increase the timeout on this darn dial-in.

UPDATE: With Ron's help I applied the l2tp command to a VPDN template then applied the template to the VPDN group. Looks like this now. I am wondering which timeout it will use, the template, or the directly configured one that I can't touch. The template I configured with "never".

vpdn-group 1
 ! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 2
 source vpdn-template 2
 l2tp tunnel timeout no-session 15

Also, a question came up about licenses... here is my show license.

2901_easton#show license
Index 1 Feature: ipbasek9
        Period left: Life time
        License Type: Permanent
        License State: Active, In Use
        License Count: Non-Counted
        License Priority: Medium
Index 2 Feature: securityk9
        Period left: Life time
        License Type: Permanent
        License State: Active, In Use
        License Count: Non-Counted
        License Priority: Medium
Index 3 Feature: uck9
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 4 Feature: datak9
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 5 Feature: gatekeeper
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 6 Feature: SSL_VPN
        Period left: 8  weeks 3  days
        Period Used: 5  minutes 44 seconds
        License Type: EvalRightToUse
        License State: Active, Not in Use, EULA accepted
        License Count: 0/0  (In-use/Violation)
        License Priority: Low
Index 7 Feature: ios-ips-update
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 8 Feature: SNASw
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 9 Feature: hseck9
Index 10 Feature: cme-srst
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: 0/0  (In-use/Violation)
        License Priority: None
Index 11 Feature: WAAS_Express
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 12 Feature: UCVideo
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
12
  • What IOS version are you using? – Ron Maupin Aug 26 '16 at 16:02
  • 15.1(4)M3 Also, how do you put commands into those grey blocks you just added? thanks. – Helkas Aug 26 '16 at 16:04
  • Fat fingered the version... please see corrected version above. – Helkas Aug 26 '16 at 16:08
  • 2
    Highlight a block of text, then click the Preformatted Text button: {}. – Ron Maupin Aug 26 '16 at 16:16
  • 1
    As far as I can tell, that command should work. It does say it can be configured on the template. Have you tried that? See page VPD-115 in cisco.com/c/en/us/td/docs/ios/vpdn/command/reference/… – Ron Maupin Aug 26 '16 at 16:22
3

EDIT: Short Answer is that PPTP protocol was selected and the l2tp options for the timeout were unavailable in this context. Changing the protocol to l2tp under the vpdn-group allows you to remove and configure the l2tp settings.

I don't have enough rep to comment so I will post an answer here... I have a similar configuration and I am able to edit the session timeout under the vpdn group.

uc520(config-vpdn)#?
VPDN group configuration commands:
  accept-dialin             VPDN accept-dialin group configuration
  default                   Set a command to its defaults
  description               Description for this VPDN group
  dsl-line-info-forwarding  Forward DSL Line Info attributes
  exit                      Exit from VPDN group configuration mode
  force-local-chap          Force a CHAP challenge to be instigated locally
  ip                        IP settings for tunnel
  l2tp                      L2TP specific commands
  lcp                       LCP specific commands
  local                     Local information
  no                        Negate a command or set its defaults
  redirect                  Call redirection options
  relay                     Relay options configuration
  request-dialout           VPDN request-dialout group configuration
  scalability               Scalability testing configuration
  session-limit             Maximum sessions allowed for this group
  source                    Configuration source for this vpdn-group
  source-ip                 Set source IP address for this vpdn-group
  terminate-from            Terminate tunnel from remote peer
  vpn                       VPN ID/VRF name

I am running IOS version Version 15.1(4)M6 which is a few maintenance releases newer than the one you are using. I would try updating it.

EDIT: Here is the VPDN configuration

VPDN Configuration
vpdn enable
!
vpdn-group L2TP
 ! Default L2TP VPDN group
 accept-dialin
  protocol l2tp
  virtual-template 1
 no l2tp tunnel authentication

IOS Image: uc500-advipservicesk9-mz.151-4.M6

This configuration is on a UC520 so the licensing is user based. It doesn't show anything related to features.

Looking at that, you may be able to remove the command by changing the protocol, removing it, and then changing the protocol back. Then you could try this command:

pptp tunnel echo [time_out]

I didn't realize you were using PPTP.

Josh

5
  • @Helkas, I wonder if there is a license difference. If you both do a show license, we can compare. – Ron Maupin Aug 26 '16 at 17:34
  • Ill post it in the main section. – Helkas Aug 26 '16 at 17:37
  • Hey Josh, if you have a vpdn-group, can you tell me what protocol you are using under your "accept-dialin" command? I am wondering if i don't see the command because the group is set to use pptp. --Thanks Ron for the VDPN documentation. – Helkas Aug 26 '16 at 17:53
  • So do I understand correctly that in short the answer is, you were unable to set l2tp specific parameters because you were not using l2tp? – hertitu Aug 26 '16 at 22:42
  • Yes. Or more specifically, l2tp options do not appear if you do not have the l2tp protocol enabled, as you can have the dial in set to accept both pptp and l2tp. The gotcha is that if you set l2tp parameters, then remove the l2tp protocol, the parameters you configured for l2tp will stay on the running config, with you unable to remove them. Lesson learned. =P – Helkas Aug 29 '16 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.