I hope you can help me with this problem...

I'm have installed 2 Juniper Switch EX3300 for my DC, the link from coreswitch to Switch no 1 (using FO) is fine...they working normally, but from switch no 1 to no 2 is not working. the connection between core switch no 1 and no 2 is using 10GE SFP+ SR. I've already try to switch from 1 slot to another slot (there's 4 slot sfp), either than the SFP. Can anyone please help me...

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 15, 2017 at 1:44

3 Answers 3


Out of the box, the EX3300 has the last two SFP ports in Virtual-Chassis mode (ge-0/1/2 and ge-0/1/3).


request virtual-chassis vc-port delete pic-slot 1 port 2
request virtual-chassis vc-port delete pic-slot 1 port 3

to turn them back to standard Ethernet interfaces.

  • You can confirm this by doing: show virtual-chassis vc-port
    – Firebirdnz
    Oct 31, 2016 at 1:08
  • 2
    If anyone is still having a problem with this, i was struggeling today with it but it s working. With the commands from Benjamin Dales and after you turn the ports to discoverable, you add them in vlans and thats all.
    – Alex Tudor
    Dec 8, 2021 at 14:21

If I understood well switch number 2 is also connected to the coreswitch, right? If so maybe you have a spanning tree loop and the connection between those two EX3300 is being blocked.
This is a good guide from Juniper to troubleshoot spanning tree protocol.

You can also use the command show interfaces diagnostics optics xe-x/y/z in each switch and check the Receiver signal average optical power for the interfaces that connect switch number 1 to switch number 2.

  • no....switch number 2 connected to switch number 1 using FO
    – iBam'S
    Aug 30, 2016 at 2:28
  • no....switch number 2 connected to switch number 1 using FO, i already try that command and the result is "Receiver signal average optical power : 0.0000 mW / - Inf dBm" for both switch
    – iBam'S
    Aug 30, 2016 at 2:34
  • Is this the topology? CoreSwitch --> EX3300-1 --> EX3300-2 Is EX3300-2 connected to another switch or just to EX3300-1?
    – xpto
    Aug 30, 2016 at 10:14
  • Have you also tried to used another FO? Or change the rx/tx terminations in one end of the fiber?
    – xpto
    Aug 30, 2016 at 10:24
  • yes xpto....that's right...it just from ex3300-1... i also already tried with another FO
    – iBam'S
    Sep 4, 2016 at 8:33

The 10G SFPs needs to be Juniper compatible. Check if the SFP are registred by the switch with the "show chassis hardware" command. If they are compatible, you need to eliminate any potential hardware issues with the 10G SFPs or damage to the optical cable/ODF.

Take a fiber optical cable, make a loop in each SFP and see if there is link. If not, then you have a problem with one of the SFPs.

If you are using a ODF, make a loop in one end and see if there is link. If not, then you have a problem with the optical cable/ODF.

  • the SFP is registered by the switch, and i already try to make a loop on each SFP and the result is there's a a link
    – iBam'S
    Aug 30, 2016 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.