1

In one of our plants, we've got an issue with the SFP, where we are not able connect two 2960s via a Fiber Link. My question is: are there any configation options, that can prevent the link to go up? (except media-type RJ-45)

Regards

  • Could you provide more details? What does the port say when you do a sh int status? Does the switch recognize the SFPs? Could you also post the configurations for the port on each switch? That will assist us in helping to troubleshoot. – Zack Scaringello Sep 1 '16 at 12:50
  • Sh int status shows not connected: sh run on the interfaces shows only switchport mode trunk and media-type sfp; SFPs are 1000-BaseLX; Switch does not have DOM so I can't monitor the parameters – reybanger Sep 1 '16 at 12:53
  • are you sure it is not sfp+ and you insert it int 1G fiber port – Gadeliow Sep 1 '16 at 13:19
  • 3
    Have you tested the fiber? Have you swapped tx and rx? – Ron Trunk Sep 1 '16 at 14:00
  • 1
    With 1000BASE-LX, you may need to use an attenuator for short fiber runs. – Ron Maupin Sep 1 '16 at 14:08
2

As far as I am concerned, the most common SFP problems are Poor performance, No connectivity and Corrupted software.

For the first one, the possible cause of this problem include that cabling distance is exceeded or port statistics show excessive frame check sequence (FCS), late-collision, or alignment errors.

Resolution: Reduce the cable length to within the recommended distances. See your SFP module documentation for cabling guidelines.

For the comnectivity issue, maybe you have used the incorrect ot bad cable, or STP (Shielded Twisted Pair) checking for possible loops.

Resolution: Verify the pinouts are correct for the proper application of cables. Replace the cable with a tested good cable. Wait 30 seconds for the port LED to turn green.

For the third issue—corrupted software, this include three situation including the port is placed in error-disabled state after SFP is inserted, device does not recognize the SFP module, and excessive errors found in port statistics.

Resolution: Remove the SFP module from the switch and replace it with a Cisco-approved module. Use the irrdisable recovery cause GBIC-invalid global configuration command to verify the port status, and enter a time interval to recover from the error-disable state. The best advice is to use the Cisco original SFP or 100% Cisco compatible SFP (If you decide to use a third-party SFP, please ensure that your supplier is assured) that is adapted to the switch.

Hope this might help you!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.