I Have two Juniper ACX 2200 Series Routers connected back to back and One Router running latest OS, But other is running Old OS,

I want to copy Latest OS from One Junos to another Junos Router,

I enabled FTP On both Routers

[edit system services ftp]
set rate-limit 2
set connection-limit 2

And Used The Command

ikar@hostname> file copy ftp://ikar:[email protected]/var/tmp/jinstall-ppc-15.1X54-D36.2-domestic.tgz /var/tmp

And I got the Below Error

fetch: ftp://ikar:*@ File unavailable (e.g., file not found, no access)
error: file-fetch failed
error: could not fetch local copy of file

User : ikar has Super-user privilages.

  • 1
    Have you tried connecting using an ordinary ftp client rather than Junipers? It might give you more information in regards to access perhaps. I know it's a silly question, but have you double checked that the file is actually present on the source? Alternatively, try using SCP if you have SSH setup using scp://user@hostname/path/filename
    – SleepyMan
    Sep 9, 2016 at 14:56
  • @SleepyMan It works with external ftp client, and file exists in the /var/tmp directoy, I asked this question because in case if routers lost connectivity to external ftp clent , i should be able transfer images via another router,
    – R__raki__
    Sep 9, 2016 at 15:01
  • @SleepyMan thanks for suggesting scp, i will try with it.
    – R__raki__
    Sep 9, 2016 at 15:01
  • @SleepyMan And also I don't happen to find specific documents where copying junos OS from one router to another is mentioned . If you have one please mention it.
    – R__raki__
    Sep 9, 2016 at 15:04
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 15, 2017 at 1:52

2 Answers 2


If you are having problems in getting the URL right, jump into the FreeBSD shell (using "start shell") and do the ftp from there:

user@router> start shell
% ftp
Connected to
220 router FTP server (Version 6.00LS) ready.
Name ( user
331 Password required for user.
230 User user logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> bin
200 Type set to I.
ftp> get <file>


ikar@hostname> file copy ftp://[email protected]/var/tmp/jinstall-ppc-15.1X54-D36.2-domestic.tgz /var/tmp

You'll be prompted for password, put in the password and you should be good to go

(Source: http://www.juniper.net/documentation/en_US/junos15.1/topics/reference/command-summary/file-copy.html#jd0e160)

  • I have already tried that one, it will give the same error, by the way both methods are same.
    – R__raki__
    Sep 9, 2016 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.