6

I've got a cisco 1921 in a lab setting where we've added an extra interface (EHWIC-1GE-SFP-CU) and as long as a network cable is connected it works fine.

However if the network cable is disconnected and then reconnected the inteface doesn't start up again until I log into the router, enter config mode for the interface and issue

shutdown

wait for a while and then issue

no shutdown

Doing this makes everything work again, but in a production setting that is, unfortunately, not a viable option. Why does this happen? Is it a hardware fault? Config issue?

interface GigabitEthernet0/0/0
 ip address 10.0.4.35 255.255.255.0
 no ip redirects
 duplex half
 speed 10
 no cdp enable
!
  • The cisco IOS are updated? They had a lot of bugs. try 15.1.4M4 IOS or later. This link will help you – Danilo Breda Oct 7 '13 at 13:30
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 8 '17 at 21:22
4

You should be able to hard code speed / duplex and get the interface to go up / down without kicking it. Unless there is a problem with the cable, or the hub it's connected to, that behavior looks like a bug...

Open a TAC case, or get a $25 switch from walmart that can autonegotiate.

| improve this answer | |
  • the speed and duplex settings is because on the other end of the cable there is an old hardware encryption box that needs those settings. We've tried another cable and other equipment, but the problem remains – Johannes Nordh Oct 4 '13 at 10:59
  • @JohannesNordh, understandable... as much as I hate recommending unmanaged hubs, the walmart hub could still serve as useful duct tape since you have to live with this old HW... or you could write an EEM script to shut / no shut the interface every ten seconds while line protocol is down to that host. If you go the hub route, you might need IP SLA tracking track the IP reachability of the device, since the hub will always be up. – Mike Pennington Oct 4 '13 at 11:05
  • @MikePennington Mike, would it help to put the interface in "no keepalive" in this case? – Bulki Oct 4 '13 at 13:54
  • @Bulki, no keepalive might assist as well... the OP could try that – Mike Pennington Oct 4 '13 at 16:47
2

Have you tried spanning-tree portfast? I've used this before in situations when a device wouldn't connect properly without intervention, even with a hard-set port.

| improve this answer | |
0

You must statically set the media-type on the interface. If you are using SFP port issue the "media-type sfp" command under the interface. If you are using RJ45 port issue the "media-type rj45" command under the interface.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.