0

I have two Cisco switches connected with two trunk links.

On the first switch spanning tree is switched off.

On the second switch, MST is turned on.

Ports configuration is as follows:

interface Ethernet0/2
switchport trunk allowed vlan 2-4
switchport trunk encapsulation dot1q
switchport trunk native vlan 4
switchport mode trunk
!
interface Ethernet0/3
switchport trunk allowed vlan 2-4
switchport trunk encapsulation dot1q
switchport trunk native vlan 4
switchport mode trunk

(the configuration is the same on both switches)

I expect switch #2 to block one of the trunk ports: however, both of them are in FORWARDING.

I dumped traffic between two switches and I saw no BPDUs are send back to switch #2. Switch #1 receives them but instead of sending them back to switch #2 does nothing.

When I change native vlan to 1 (and allow it on trunk link), everything works correctly and one of the ports is being blocked.

Why it happens?

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 15 '17 at 2:31
2

MST works as a common spanning tree(CST). This means that MST doesn't generate sperate bpdu for each vlan. Only PVST(+) can generate bpdu per vlan. MST will send and accept bpdu over Vlan1 when you connect MST to none-mst domain. So in your case you have to allow vlan 1.

  • Do you have a source for that? I could very well be wrong but I thought MST used untagged BPDUs. – hertitu Sep 15 '16 at 21:37
  • MST uses untagged bpdu, and sends it via native vlan only within MST domain. But in this case you are connecting to non-MST domain, as you have disabled stp on other switch. So it will send bpdu's and process them only over vlan1. I have integrated MST and PVST domains in my datacenter, and i know how ugly it looks. I would recomend using only PVST+ in your network. Please see this link about VLAN1 : cisco.com/c/en/us/support/docs/lan-switching/… – Nuran Afrasiyabov Sep 16 '16 at 10:31
  • Sounds convincing, but please note I mirrored traffic between switch #2 and switch #1, and switch #2 is sending BPDUs to switch #1 (though it shouldn't, according to your assumption). In my opinion, the key to problem is somewhere in logic of switch #1 - it's not sending BPDUs back in native vlan other from vlan 1. – grindelwaldus Sep 16 '16 at 13:02
  • How did you disable STP on first switch ? can you share the config – Nuran Afrasiyabov Sep 16 '16 at 15:09
  • I can't provide exact configuration right now, but I disabled spanning tree in vlans 1-4 (with no spanning-tree vlan 1-4). I made sure STP is disabled with show spanning-tree. – grindelwaldus Sep 16 '16 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.