1

I'm setting up BFD on BGP between ASR1k and ASR9k. On 1k #show bfd neighbors details dosn't produce any output. Seems like BFD is not running. CPU Proccess running on 1k: BFD HW EVENT, BFD IPV6 ADDR, BFD Session creation BFD HA.

We are using double tagging on sub-interface and vrf. any toughts what I'm missing? As per cisco configuration that should be easy to switch bfd on.

Please see below configuration:
router bgp 66000
 bgp router-id 10.10.10.1
 bgp log-neighbor-changes
 timers bgp 10 30
 !
 address-family ipv4 vrf 1001
  redistribute connected
  redistribute static
  neighbor x.x.x.0 remote-as 65000
  neighbor x.x.x.0 ttl-security hops 2
  neighbor x.x.x.0 fall-over bfd multi-hop
  neighbor x.x.x.0 activate
  neighbor x.x.x.0 soft-reconfiguration inbound
  neighbor y.y.y.0 remote-as 65000
  neighbor y.y.y.0 ttl-security hops 2
  neighbor y.y.y.0 fall-over bfd single-hop
  neighbor y.y.y.0 activate
  neighbor y.y.y.0 soft-reconfiguration inbound
  maximum-paths 2
  default-information originate
 exit-address-family
 !

ASR1K1#sh run int gi0/0/0.3999
interface GigabitEthernet0/0/0.3999
 description Ethernet Primary WAN
 encapsulation dot1Q 3999 second-dot1q 1
 vrf forwarding 1001
 ip address x.x.x.1 255.255.255.254
 bfd interval 500 min_rx 100 multiplier 3
end

ASR1K1#sh run int Gi0/0/1.3999
Building configuration...

Current configuration : 267 bytes
!
interface GigabitEthernet0/0/1.3999
 description Ethernet Secondary WAN
 encapsulation dot1Q 3999 second-dot1q 1
 vrf forwarding 1001
 ip address y.y.y.1 255.255.255.254
 bfd interval 500 min_rx 100 multiplier 3
end

Command show bfd neighbors deosn't show anything.

ASR1K1#sh bfd neighbors vrf 1001 details 
ASR1K1#

ASR9k show bfd session destination x.x.x. detail:

-------------------------------------ASR9k-1----------------------------------
RP/0/RSP0/CPU0:ASR9k1#sh bfd session destination x.x.x.1 detail 
Sun Sep 25 17:34:50.176 BST

Location: 0/2/CPU0
Dest: x.x.x.1
Src: x.x.x.0
VRF Name/ID: 1001/0x60000008
 State: DOWN for 0d:5h:32m:3s, number of times UP: 0
 Session type: SW/V4/MH
Received parameters:
 Version: 0, desired tx interval: 0 us, required rx interval: 0 us
 Multiplier: 0, diag: None
 My discr: 0, your discr: 0, H/D/F/P/C/A: 0/0/0/0/0/0
Transmitted parameters:
 Version: 1, desired tx interval: 2 s, required rx interval: 2 s
 Multiplier: 3, diag: None
 My discr: 25523, your discr: 0, state DOWN, D/F/P/C/A: 0/0/0/1/0
Timer Values:
 Local negotiated async tx interval: 2 s
 Remote negotiated async tx interval: 2 s
async detection time: 0 us
Local Stats:
 Intervals between async packets:
   Tx: Number of intervals=100, min=1665 ms, max=1998 ms, avg=1853 ms
       Last packet transmitted 338 ms ago
   Rx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
       Last packet received 0 s ago
MP download state: BFD_MP_DOWNLOAD_ACK
State change time: Sep 25 12:02:46.886
Session owner information:
                            Desired               Adjusted
  Client               Interval   Multiplier Interval   Multiplier
  -------------------- --------------------- ---------------------
  bgp-default          500 ms     3          2 s        3         
  bgp-default          500 ms     3          2 s        3      

-------------------------------------ASR9k-2----------------------------------      

RP/0/RSP0/CPU0:ASR9k2#sh bfd session destination y.y.y.1 detail 
Sun Sep 25 17:34:05.477 BST
I/f: GigabitEthernet0/3/0/0.3999, Location: 0/3/CPU0
Dest: y.y.y.1
Src: y.y.y.0
 State: DOWN for 2d:1h:34m:36s, number of times UP: 0
 Session type: PR/V4/SH
Received parameters:
 Version: 0, desired tx interval: 0 us, required rx interval: 0 us
 Required echo rx interval: 0 us, multiplier: 0, diag: None
 My discr: 0, your discr: 0, H/D/F/P/C/A: 0/0/0/0/0/0
Transmitted parameters:
 Version: 1, desired tx interval: 2 s, required rx interval: 2 s
 Required echo rx interval: 1 ms, multiplier: 3, diag: None
 My discr: 456472645, your discr: 0, state DOWN, D/F/P/C/A: 0/0/0/1/0
Timer Values:
 Local negotiated async tx interval: 2 s
 Remote negotiated async tx interval: 2 s
 Desired echo tx interval: 500 ms, local negotiated echo tx interval: 0 us
 Echo detection time: 0 us, async detection time: 0 us
Local Stats:
 Intervals between async packets:
   Tx: Number of intervals=100, min=1664 ms, max=2 s, avg=1846 ms
       Last packet transmitted 1811 ms ago
   Rx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
       Last packet received 0 s ago
 Intervals between echo packets:
   Tx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
       Last packet transmitted 0 s ago
   Rx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
       Last packet received 0 s ago
 Latency of echo packets (time between tx and rx):
   Number of packets: 0, min=0 us, max=0 us, avg=0 us
Session owner information:
                            Desired               Adjusted
  Client               Interval   Multiplier Interval   Multiplier
  -------------------- --------------------- ---------------------
  bgp-default          500 ms     3          2 s        3         
  bgp-default          500 ms     3          2 s        3         
  • 1
    Are you running BFD on both ends? You only show one end here. – Ron Maupin Sep 25 '16 at 16:53
  • 1
    Are you sure BFD isn't dropped by CoPP? – Teun Vink Sep 25 '16 at 20:30
  • 1
    What are the IOS versions & feature sets on both sides, and have you tried any of the debug bfd * commands? – hertitu Sep 26 '16 at 8:19
  • 1
    And why is multi-hop enabled for x.x.x.0, since it seems to be directly connected? – hertitu Sep 26 '16 at 9:02
  • 1
    sh bfd drop might also provide some clues. – hertitu Sep 26 '16 at 13:37
1

Configuring Bidirectional Forwarding Detection on the Cisco ASR 9000 Series Router

Restrictions for Configuring BFD

The following restrictions apply to BFD:

  1. If you are using BFD with uRPF on a particular interface, then you need to use the echo disable command to disable echo mode on that interface; otherwise, echo packets are rejected. You can disable echo mode for the entire router, or for an individual interface.
  2. Only the static, OSPF, and IS-IS applications are supported on BFD over bundle VLANs.
1

if BFD Session Not Coming Up, may you follow the next steps to overcome this issue:

  • Was the session created by the application?

Use the "show bfd all session" command to see if the session has been created. If the session is not visible using the bfd show command, check that the adjacency for which the BFD session is being created exists in the application.

  • Can you ping the destination address for which the BFD session is to be created?

The BFD session will only be created by an application for which the application adjacency/neighbour exists.

  • Has BFD been configured on both sides?

  • Has BFD been configured with correct destination address?

Using non-default IP addresses with BFD requires special attention. The source IP address being used for BFD sessions can be verified with "show bfd all session detail" command.

also you can find useful troubleshooting steps in this link support

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.