2

networking question above i have two L3 switches. ESW1 has vlan 10 and 20 ESW2 has vlan 10 and 30 (the same ten)

when i configure OSPF on both ESW1 and ESW2 it doesn't neighbor. I want OSPF to advertise vlan 20 to ESW2 and vlan 30 to ESW1

I did create a SVI for Vlan 20 on ESW2 and 30 on ESW3 so they could talk.

I just want to know if its possible to have OSPF advertising the unique Vlans to each other in area 0.

ESW1 Config

interface Vlan1 
no ip address 
shutdown 
! 
interface Vlan10 
ip address 10.10.10.254 255.255.255.0 
ip ospf network point-to-point 
! 
interface Vlan20
 ip address 10.10.20.254 255.255.255.0 
! 
router ospf 1 
log-adjacency-changes 
network 10.10.20.0 0.0.0.255 area 0 
! 
ip forward-protocol nd 
! 
! 
no ip http server 
no ip http secure-server 
! 
no cdp log mismatch duplex 
! 
!

ESW 2

! 
interface Vlan1 
no ip address 
shutdown 
! 
interface Vlan10 
ip address 10.10.10.253 255.255.255.0 
ip ospf network point-to-point 
! 
interface Vlan30 
ip address 10.10.30.254 255.255.255.0 
! 
router ospf 1 
log-adjacency-changes 
network 10.10.30.0 0.0.0.255 area 0 
!
9
  • What VLAN are you using to establish neighbors?
    – Ron Trunk
    Sep 26, 2016 at 11:47
  • 2
    if its possible to have OSPF advertising the unique Vlans : no, ospf does not advertise vlans. I guess you may mean "... to have OSPF advertising the unique subnets". That should definitely be possible. Please post your config of ESW1 and ESW2 so we can check what might be wrong. BTW your 3rd paragraph mentions ESW2 and ESW3, I suppose that is a typo?
    – hertitu
    Sep 26, 2016 at 11:51
  • please provide the configurations you did
    – Gadeliow
    Sep 26, 2016 at 11:52
  • Hi all thanks for the prompt reply. yes my apologies I want to I want to advertise the 10.10.20.0/24 network to ESW2 and 10.10.30.0/24 to ESW1.
    – RJTuck1
    Sep 26, 2016 at 12:22
  • Yes the the ESW2/3 thing was a typo. posting config now.
    – RJTuck1
    Sep 26, 2016 at 12:23

3 Answers 3

3

You need to include VLAN 10 in your OSPF configuration. You have only specified that OSPF uses the interfaces on VLANs 20 and 30. OSPF needs a common subnet in order to create adjacencies.

You can add the network statement

network 10.10.10.0 0.0.0.255 area 0

to your OSPF config on both routers

1
  • Thank you Ron, I couldn't see the trees for the forest. works a treat now.
    – RJTuck1
    Sep 27, 2016 at 14:19
0

the dot1q trunk is L2 , so you should configure L3 link between the 2 switches. you may need to configure link aggregation between the two switches then assign IPs in same range for the two switches and then try the OSPF configurations.

0

OSPF does not advertise VLAN information. Cisco's VTP does. OSPF does not form peering sessions like BGP does, it establishes neighbor relationships; the time to live (TTL) value of OSPF packets is 1.

To get your OSPF processes to establish a neighbor relationship, each layer 3 switch (aka router) needs to share a layer2 (Ethernet) link and IP subnet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.