9

We recently bought some new AP3602Es from Cisco.

I'm trying to understand why this AP will not turn on the radio when we are sending enough power to the AP. I'm using inline power from the switch, but after the AP comes on, it sends %CDP_PD-2-POWER_LOW: All radios disabled to the console. The LED on the AP flashes green.

Topology:

+---------------+ Gi1/0/1   Gi0/1 +-----------+
|   AP_Test     |                 |           |
|   Cat2960S    |-----------------|  AP3602E  |
|               |                 |           |
+---------------+                 +-----------+
                       <------- cdp Req 13000mW
power inline 13000mW ------->

The AP is running a 12.4(25e)JAL1a rcvk9w8 receive image.

The 2960S is running 12.2(55)SE7.

Question: How can I make this AP turn on the radios?


Misc output...

debug cdp ilp...

AP0006.6566.a57b#debug cdp ilp
*May  8 00:11:54.391: CDP-ILP: sent cdp msg:power consumed  pwr=13000
*May  8 00:11:54.391: CDP-ILP: sent cdp msg:power request reqid=47837 manid=3 rlevel(1)=13000
*May  8 00:11:54.635: CDP-ILP: rcvd cdp msg:power available reqid=47837 manid=3 alevel=13000 mlevel=13000
*May  8 00:11:54.635: CDP-ILP: power state:NEGOTIATED_UNCHANGED event:BOTH_ID_unCHANGED unchanged
AP0006.6566.a57b#

show power inline...

AP_Test#show power inline gi1/0/1
Interface Admin  Oper       Power   Device              Class Max
                            (Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Gi1/0/1   auto   on         13.0    AIR-CAP3602E-A-K9     4   30.0

Interface  AdminPowerMax   AdminConsumption
             (Watts)           (Watts)
---------- --------------- ------------------

Gi1/0/1        30.0             30.0
AP_Test#

2960S switch port interface configuration...

!
interface GigabitEthernet1/0/1
 switchport access vlan 385
 switchport mode access
 switchport nonegotiate
 switchport port-security
 switchport port-security aging time 5
 switchport port-security violation protect
 switchport port-security aging type inactivity
 storm-control broadcast level 0.50
 storm-control action trap
 spanning-tree portfast
 spanning-tree bpduguard enable
end
10

it sends %CDP_PD-2-POWER_LOW: All radios disabled to the console...
Question: How can I make this AP turn on the radios?

I talked with a Cisco Wireless Consulting SE... The first problem is that the recovery image (i.e. rcv-w8 image) does not have the firmware for Dot11 radios... so I had to upload new firmware.

I normally use archive download-sw /force-reload /overwrite tftp://... to upgrade the image when I am dealing with older Cisco AP 1242 models; however, under this image I kept getting an error until I used debug capwap console cli...

AP0006.6566.a57b#arch?
% Unrecognized command
AP0006.6566.a57b#debug capwap console cli
AP0006.6566.a57b#arch?
archive

AP0006.6566.a57b#archive download-sw /force-reload /overwrite tftp://192.0.2.100/ap32g2-k9w7-tar.152-4.JA1.tar

After upgrading to ap32g2-k9w7-tar.152-4.JA1.tar (the w7 is an autonomous AP image) the Dot11radio interfaces came up.


Purely informational... this is the open-auth autonomous AP config we're using for our 2.4G and 5.0G survey...

!
version 15.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname Survey_AP
!
!
logging rate-limit console 9
enable secret Cisco
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
clock timezone CST -6 0
clock summer-time CDT recurring
no ip source-route
no ip routing
no ip cef
!
!
!
!
login on-failure log
login on-success log
dot11 syslog
!
dot11 ssid WifiSurvey
   vlan 1
   max-associations 50
   authentication open
   mbssid guest-mode
!
!
dot11 guest
!
!
!
username Cisco password 7 05280F1C2243
!
ip dhcp excluded-address 192.0.2.254
!
ip dhcp pool SURVEY_DHCP
 network 192.0.2.0 255.255.255.0
 lease 0 0 15
 domain-name survey.local
 default-router 192.0.2.254
 dns-server 192.0.2.254
!
!
bridge irb
!
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 ssid WifiSurvey
 no shutdown
 !
 antenna gain 0
 ! Block access to 802.11b clients: set 12Mbps as required speed
 speed basic-12.0 m0-7 m8-15
 ! Optional: Power is specified in mW
 ! power local 11
 ! power client 11
 stbc
 mbssid
 station-role root
 world-mode dot11d country-code US indoor
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 !
 ssid WifiSurvey
 no shutdown
 !
 antenna gain 0
 ! Block access to 802.11b clients: set 12Mbps as required speed
 speed basic-12.0 m0-7 m8-15
 ! Optional: Power is specified in mW
 ! power local 11
 ! power client 11
 peakdetect
 dfs band 3 block
 stbc
 mbssid
 channel dfs
 station-role root
 world-mode dot11d country-code US indoor
!
interface Dot11Radio1.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 bridge-group 1 spanning-disabled
 no bridge-group 1 source-learning
!
interface BVI1
 ip address 192.0.2.254 255.255.255.0
 no ip route-cache
 ipv6 address dhcp
 ipv6 address autoconfig
 ipv6 enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
!
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 transport preferred none
 transport input all
!
end
  • Time has been limited and I completely missed that this was a recovery image, but that would definitely explain the problem. Glad you found the answer. – YLearn Oct 9 '13 at 19:20
  • It's no problem... I am still looking for the place where Cisco tells you that the receive image doesn't have radio firmware... and it's pretty bogus that they give you a CDP error when they don't have the firmware in the image... regardless, I got the radios on so we can do a site survey. – Mike Pennington Oct 10 '13 at 17:59
6

Some 3600's do require 802.3at power and it looks like this one does, and for some reason it is only drawing 802.3af power levels. Not sure if there is a bug in either the switch or AP code that could cause this, but here are a couple things to try.

In some cases (usually with non-Cisco devices) I have had to add on the following on the interface (shut the interface before adding/removing):

power inline port 2x-mode

If that doesn't do it, sometimes disabling CDP on the interface can help by forcing it into using the IEEE class negotiation for 802.3at rather than CDP. Often not as power efficient, but may resolve the issue.

  • 1
    From what I see in debug cdp ilp on the LWAP, it's only requesting 13000mW. I did try power inline power 2x-mode and power inline static max 30000 before posting the question and that did not help... but I did it more as a shot in the dark without knowing of any real requirement for it... do you know of any online documents that mention 802.3at requirements on AIR-CAP3602E? The data sheet clearly says it only needs 12.95W – Mike Pennington Oct 8 '13 at 18:04
  • I found mention of 3600's with attached module requiring 802.3at in this document for one. I believe I have seen it elsewhere as well. – YLearn Oct 8 '13 at 19:01
  • Thanks... the power document you mentioned says that the AP should fall back automatically when connected to an 802.3af source. This is starting to sound like an AP problem... I'm going to change the AP's code, but I should at least upvote for helping me isolate where the fault is. – Mike Pennington Oct 8 '13 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.