8

I'm setting up dhcp snooping with IP source guard and DAI on some 3com S4210 switches.

I found problem with recording bindings in snooping database. In some cases I know that there is PC connected to interface, it use the DHCP, even switch say in debbuging that there are DHCP traffic, connection on PC works with assigned address but there's no record when I execute display dhcp-snooping command.

By making some experiments on table lab I found that if DHCP traffic goes within 2 access ports (both client and server are at same vlan, both connected to access ports) than it is recorded.

After than I connected DHCP to trunk interface (as it is in live network, DHCP server is connected to another switch and there is relay on router), when DHCP is communicating at untagged vlan of that trunk the binding is recorded (same behavior if use client on access port with vlan 1 or client connected on port with access vlan X and I set on trunk port command port trunk pvid vlan X).

If DHCP traffic comes tagged throw trunk the binding is not recorded on switch. In all cases no matter how it is configured client receives correct address from DHCP and can communicate correctly.

Without proper working binding db I can't enable IP source guard and DAI.

I have latest FW for this switch available (wasn't easy to find it on HP webpages but Google helped after some time)

By Google i found that on Cisco products you need to enable dhcp-snooping for vlans but on 3com did'nt find anything similar in documentation or any similar command in switch command line.

Did anybody had these issues to and figured out where is problem?

Can't ask HP directly because our technical support warranty already expired and they won't talk to me (tried in different situation).

Thanks for answers.

Michal

  • Can you post your relevant DHCP-snooping configurations? – Ryan Foley Feb 21 '14 at 13:22
  • Fizzle: sorry for delay, didn't checked this page so frequently. Configuration is simple. Just enabled it by dhcp-snooping command and set trusted interface interface GigabitEthernet1/0/50 dhcp-snooping trust – skvedo Mar 18 '14 at 8:28
  • Where is the relay agent in reference to the dhcp-snooping switch? – Ryan Foley Mar 18 '14 at 9:48
  • In this lab configuration I have directly connected DHCP server device on interface Gi1/0/50 – skvedo Mar 18 '14 at 10:17
  • Is the switch you're trying to enable dhcp-snooping on a relay agent or routing between the VLANs? – Ryan Foley Mar 18 '14 at 10:36
2

In order for dhcp-snooping to function correctly, the snooping device needs to be setup as just a layer 2 device (i.e. not performing DHCP functions at all). There are a few gotcha’s from 3Com's documentation, 3Com® Switch 4500G Family Configuration Guide (p. 405), which should still be applicable to your platform.

The DHCP Snooping supports no link aggregation. If an Ethernet port is added into an aggregation group, DHCP Snooping configuration on it will not take effect. When the port is removed from the group, DHCP Snooping can take effect.

If you have aggregated uplink ports (802.3ax), the link won’t be snooped on.

The DHCP snooping enabled device does not work if it is between the DHCP relay agent and DHCP server, and it can work when it is between the DHCP client and relay agent or between the DHCP client and server.

In your test bed scenario, you basically had a client and a server connected into 2 different access ports; one a trusted DHCP port. This is the simplest way to setup DHCP-snooping. Had this of gone wrong, I would suspect there is another, underlying issue/configuration mistake.

The DHCP Snooping enabled device cannot be a DHCP server, DHCP relay agent, DHCP client, or BOOTP client. Therefore, DHCP Snooping must be disabled on a DHCP server, relay agent, DHCP relay agent, DHCP client, and BOOTP client.

What this final bit means is that you really can’t have your switch performing any DHCP functions, aside from DHCP-snooping.

In the comments, you stated ”it is just L2 device”. I would check over your configurations more thoroughly, because you are attempting to implement that absolute basic configurations needed for DHCP snooping to function. You tested it on your test network, and it worked fine. Now your production network, with seemingly identical configurations, isn't working.

Below are basic configuration procedures from the 3Com documentation; if these don't work, I would certainly be looking elsewhere.

1  Enable DHCP snooping.
   <Sysname> system-view
   [Sysname] dhcp-snooping
2  Specify GigabitEthernet1/0/1 as trusted.
   [Sysname] interface GigabitEthernet1/0/1
   [Sysname-GigabitEthernet1/0/1] dhcp-snooping trust
  • I have checked the configuration again. You can see it there (just altered addresses and passwords hashes, deletes unused interfaces config) :pastebin.com/uniME5fT . Recently configuring DHCP snooping on Cisco gear find in doc, that you need to have option 82 insertion enabled. Tried it on 3com, but no difference at all. Still same problem. If answers from DHCP server are send to switch in 802.1q tagged frames, bounding is not recorded in switch. – skvedo Apr 14 '14 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.