1

diagram

This is a simplified version of my network diagram. How do I make both network speak to each other?

I'm confused because earlier I used routers and switches, and I connected them using OSPF or EIGRP. Now, I've tried to set up EIGRP on the layer 3 switch and then on the router but I still can't ping from one network to another. I just can't understand the concept of layer 3 switches in conjunction with vlans.

These are my switches' configurations:

Switch 1:

int fa0/1
 switchport access vlan 35
!
int fa0/2
 switchport access vlan 40
!
int fa0/3
 switchport access vlan 45
!
int fa0/4
 switchport access vlan 50
!
int gig0/1
 switchport trunk encapsulation dot1q 
 switchport mode trunk
!

Switch 2:

int fa0/1
 switchport access vlan 45
!
int fa0/2
 switchport access vlan 55
!
int fa0/3
 switchport access vlan 40
!
int fa0/4
 switchport access vlan 60
!
int gig0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
int vlan 35
 ip address 10.100.50.17 255.255.255.240
!
int vlan 40
 ip address 10.100.50.33 255.255.255.240
!
int vlan 45
 ip address 10.100.50.49 255.255.255.240
!
int vlan 50
 ip address 10.100.50.65 255.255.255.240
!
int vlan 55
 ip address 10.100.50.81 255.255.255.240
!
int vlan 60
 ip address 10.100.50.97 255.255.255.240
!
exit
!
ip dhcp pool vlan35
network 10.100.50.16 255.255.255.240
default-router 10.100.50.17
!
ip dhcp pool vlan40
network 10.100.50.32 255.255.255.240
default-router 10.100.50.33
!
ip dhcp pool vlan45
network 10.100.50.48 255.255.255.240
default-router 10.100.50.49
!
ip dhcp pool vlan50
network 10.100.50.64 255.255.255.240
default-router 10.100.50.65
!
ip dhcp pool vlan55
network 10.100.50.80 255.255.255.240
default-router 10.100.50.81
!
ip dhcp pool vlan60
network 10.100.50.96 255.255.255.240
default-router 10.100.50.97
!
exit
!
end
!

The same thing is configured on another network which has 192.168.85.xx network address. I can ping from one VLAN to another inside one network but I can't do it between two networks.

I also wonder if I have to write the ip routing command on interface of the switch which is directly connected with the router.

4
  • I've tried to set up EIGRP on the layer 3 switch and then on the router => please include the EIGRP config of the switches and the complete config of the router. Also, from where to where are you testing the ping?
    – hertitu
    Oct 3, 2016 at 8:47
  • beetxt.com/aoR Initially I didn't configure EIGRP on router but after it didn't work I configured everything on everything and it still doesn't work. It even is not allowing me to ping from vlans to the router interface (18.0.0.2)
    – Josh
    Oct 3, 2016 at 22:17
  • There's a lot of stuff to be fixed there, don't have time right now to list it all (will try tomorrow if nobody else does), but I think your eigrp might actually be working (did you check neighbors and routing table?) and the ACL on the router may be simply dropping the traffic?
    – hertitu
    Oct 3, 2016 at 22:43
  • I completely deleted the ACL on the router and I'm able to ping the router, both interfaces, but I can't reach the other network
    – Josh
    Oct 3, 2016 at 22:51

2 Answers 2

0

Unless you enable routing on a layer-3 switch, it is only doing layer-2 switching, not anything with layer-3.

How do you suppose that the networks on one side know where to send traffic destined for the networks on the other side? Routers, including layer-3 switches, need to know where to send traffic, otherwise the traffic gets dropped. Routers get routers three ways:

  1. Directly connected networks
  2. Statically configured routes
  3. Dynamically learned routes from routing protocols

You either need to manually configure routes, or you need to run a routing protocols between the layer-3 devices.

The real way to do it is to configure IP routing on all the layer-3 switches, and configure the links between the layer-3 switches and the router to be routed links, not trunks. Then you run a common routing protocol on all the layer-3 devices.

1
0

Each VLAN is a network, Basically according to your diagram you have 9 networks, with a Router you don't need to do routing with a layer-3 switch, However maybe you don't have 9 ports on your router for your 9 networks, in this situation, you can use a technique called router on a stick by creating virtual port for each vlan, here is an example.

on the router

Interface Fa0/1 ip address 192.168.10.1 255.255.255.240 interface Fa0/1.2 encapsulation dot1q 2 ip address 192.168.1.65 255.255.255.192 interface Fa0/1.10 encapsulation dot1q 10 ip address 192.168.1.129 255.255.255.224

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.