1

Why does HSRP shows both sides are active HSRP? Could you please give me details answer?

First router:

**Vlan111 - Group 6**
  State is Active
    5 state changes, last state change 2w4d
  Virtual IP address is 10.101.59.1
  Active virtual MAC address is 0000.0c07.ac06 (MAC In Use)
    Local virtual MAC address is 0000.0c07.ac06 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.272 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is unknown
  Priority 100 (default 100)
  Group name is "hsrp-Vl111-6" (default)

**r-ca-103-1#show run interface vlan 111**
Building configuration...

Current configuration : 433 bytes
!
interface Vlan111
 vrf forwarding 901_general
 ip address 10.101.59.2 255.255.255.0
 ip access-group Student-Access in
 ip helper-address 10.39.0.119
 ip helper-address 10.180.1.20
 ip helper-address 10.180.1.21
 ip helper-address 10.180.1.23
 ip helper-address 10.180.1.24
 no ip redirects
 no ip unreachables
 ip directed-broadcast 101
 ip pim sparse-dense-mode
 standby 6 ip 10.101.59.1
 standby 6 preempt delay minimum 30
end

Second router :

r-ca-103-2#show standby vlan 111
Vlan111 - Group 6
  State is Active
    5 state changes, last state change 2w4d
  Virtual IP address is 10.101.59.1
  Active virtual MAC address is 0000.0c07.ac06 (MAC In Use)
    Local virtual MAC address is 0000.0c07.ac06 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.576 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is unknown
  Priority 100 (default 100)
  Group name is "hsrp-Vl111-6" (default)

r-ca-103-2#show run interface vlan 111
Building configuration...

Current configuration : 315 bytes
!
interface Vlan111
 vrf forwarding 901_general
 ip address 10.101.59.3 255.255.255.0
 ip access-group Student-Access in
 ip helper-address 10.39.0.119
 ip directed-broadcast 101
 ip pim sparse-dense-mode
 standby 1 priority 150
 standby 1 preempt
 standby 6 ip 10.101.59.1
 standby 6 preempt delay minimum 30
end
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 15 '17 at 4:35
1

Your two devices cannot communicate over that VLAN, so they cannot exchange HSRP messages on that VLAN. Each comes up thinking it is the active router. One will remain the active router, and one will become the standby router when they fight it out with the messages between them on the VLAN. Make sure that you can get from one to the other over Vlan111.

You should really have a deterministic way for this to happen. That means you should specifically set the priorities. To avoid problems, you should set the highest priority on the one with the lowest bridge priority. You want the root bridge to be the HSRP router in order to avoid a poor layer-2 path.

0

In this situation, you don't actually have load balancing, both routers are set with a priority of 100, you should set a higher priority like 110 to the one you would like to become the active router.

  • If it is not load balancing, what is it doing then? – hertitu Oct 19 '16 at 9:23
0

It appears that the two routers are not able to exchange HSRP Hello packets. I would verify that the two switches have a working Layer 2 connection for vlan111. You can see that the two routers haven't learned of each other by the fact that neither lists the other router as a member of the standby group.

As for your Preemption issue, it appears that the standby configuration of "r-ca-103-2" is incorrect. You might try changing "standby 1 priority 150" to "standby 6 priority 150" and "standby 1 preempt" to "standby 6 preempt"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.