1

Please Help !!!

Here is my topology

enter image description here

I have successfully configured vlans and svi.

I can ping all devices from vlan2 to vlan 3 but for vlan 5, i can only ping the svi. RB1 can ping RB2

Here is my running config of L3 switch "Distribution"

Distribution(config)#do sh run
Building configuration...

Current configuration : 1540 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Distribution
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 switchport mode trunk
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 5
!
interface FastEthernet0/4
 switchport access vlan 5
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
 no ip address
!
interface Vlan2
 description Utilisateurs
 ip address 172.16.2.1 255.255.255.0
!
interface Vlan3
 description Dirigeants
 ip address 172.16.3.1 255.255.255.0
!
interface Vlan4
 description Serveurs
 ip address 172.16.4.1 255.255.255.0
!
interface Vlan5
 description Coeur
 ip address 172.16.5.1 255.255.255.0
!
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

Distribution(config)#

FAI1 Configuration

Current configuration : 1114 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RB1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.5.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

FAI 2 Configurations

Current configuration : 1114 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RB2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.5.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end
  • You are not running the switch as a layer-3 switch, it is configured as a layer-2 switch. You have trunks up to the routers, so you are routing between the VLANs on the routers. You should include the router configurations. If you want the switch to be a layer-3 switch, you need to configure ip routing on the switch, and you should use the no switchport command on the interfaces to the routers, and put on IP addresses for the links to the routers. – Ron Maupin Nov 1 '16 at 23:38
  • Can some one help me? From routers of vlan 5 i can't ping svi of vlan 3 and 2. But for PC1 i can ping the svi of vlan 5 – Franklin Ndjathe Nov 1 '16 at 23:39
  • Thank y Ron Maupin. I have put "ip routing". I both interfaces of routers in the same vlan to make glbp. – Franklin Ndjathe Nov 1 '16 at 23:41
  • No, if you want the switch to be a layer-3 switch, then the switch needs the global ip routing command in the switch, and you need to set up routed links between the layer-3 switch and the routers. You need to edit your question to include the router configurations. – Ron Maupin Nov 1 '16 at 23:49
  • Ok. But when i'm setting "ip routing", i'm not seen it in running config – Franklin Ndjathe Nov 1 '16 at 23:55
2

Make sure you issue the ip routing command in EXEC mode (conf t) of your L3 distribution switch.

The rest of your config seems to be valid.

Also when you ping from the router you can try to force your ping from the right interface by issuing the following command:

RB1# ping 172.16.5.3 source interface fa0/0

And you can check that the subnet is correctly allocated to the right interface by issuing the following command:

RB1# ip route 172.16.5.3

It should say something like "directly connected through Fa0/0".

0

It depends on what you're pinging from; where is the failure from, as well. Each endpoint's subnet requires a gateway in order to reach other subnets. Further, each endpoint must know it's default gateway. If your endpoint can ping its default gateway but not other subnets, then it's the other subnet's devices that don't know how to get back to you...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.