1

How can I verify tht QoS is working for voice traffic? I also have voice server IP address. Can I also know what the session source/dest/port number info?

class-map match-all avaya
match access-group name avaya-ef
match packet length max 100

class-map match-all voice-ip
match ip precedence 5

!
policy-map qos-in
class avaya
set ip precedence 5

policy-map qos-out
class voice-ip
set ip dscp ef

interface GigabitEthernet0/0
description To LAN
ip address 172.16.3.1 255.255.255.0
no ip proxy-arp
ip accounting output-packets
duplex full
speed 100
no cdp enable
no mop enabled
service-policy input qos-in
service-policy output qos-out

ip access-list extended avaya-ef
permit ip any any dscp ef
3
  • Generally speaking in a test environment (or test window on a production environment) you can test QoS empirically by loading the network and then in the case of voice, making calls and ensuring that the quality is as expected, either by listening or by measurement using packet capture. You can do this on a unit basis or end-to-end. Routers and phones will have built-in tools to display quality information, but you have to trust them for this to be useful. However., I'm not sure that this is what you are really asking.
    – marctxk
    Nov 15, 2016 at 10:38
  • You don't actually seem to be doing anything with the markings. You really need to set a priority queue based on the marking for your outbound interface, usually the WAN interface. Simply marking the packets doesn't do anything because the default interface queues are FIFO.
    – Ron Maupin
    Nov 15, 2016 at 13:18
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 15, 2017 at 5:17

2 Answers 2

3

To see actual traffic for each class:

show policy-map interface gi0/0

In order to see actual traffic passing through the interface you'll need some kind of network sniffer with combination of port mirroring.

0

I belive there is a Netflow enabled in the router.If there is no netflow then configure the netflow.

Before that try this command " Sh ip cache verbose flow "

So you can come to know the source/destination/packets everything thing information morethan you required in this command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.