1

Having problems configuring an 1841 to allow outside access in mapping some ports to internal addresses.

Need to allow the following:

External IP: port 8080 to 192.168.3.50 External IP: port 8081 to 192.168.3.51

Here is the config of the 1841:

FT-ROUTER#sh run
Building configuration...

Current configuration : 2394 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FT-ROUTER
!
boot-start-marker
boot system flash c1841-ipbasek9-mz.124-20.T.bin
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
!
ip dhcp excluded-address 192.168.3.1 192.168.3.5
ip dhcp excluded-address 192.168.2.1 192.168.2.5
ip dhcp excluded-address 192.168.1.1 192.168.1.5
!         
ip dhcp pool MAINDATA
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1 
   dns-server 68.105.28.16 68.105.29.16 
!
ip dhcp pool PUBLICWIFI
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1 
   dns-server 68.105.28.16 68.105.29.16 
!
ip dhcp pool SECURITY
   network 192.168.3.0 255.255.255.0
   default-router 192.168.3.1 
   dns-server 68.105.28.16 68.105.29.16 
!
!
ip cef
no ip domain lookup
!

interface FastEthernet0/0
 ip address 98.190.71.2 255.255.255.240
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.100
 description FT-MAIN-DATA
 encapsulation dot1Q 100
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/1.200
 description FT-PUBLIC-WIRELESS
 encapsulation dot1Q 200
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/1.300
 encapsulation dot1Q 300
 ip address 192.168.3.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!

!
ip default-gateway 98.190.71.1
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 98.190.71.1
!
ip nat inside source list 10 interface FastEthernet0/0 overload
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.2.0 0.0.0.255
access-list 10 permit 192.168.3.0 0.0.0.255

Here is a basic diagram:

Network Diagram

  • Why would you want your networking equipment to change the port number? Just curious... – Ronnie Royston Jan 16 '17 at 1:04
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 15 '17 at 5:17
2

Below is a regular Static PAT statement.

ip nat inside source static tcp 192.168.3.50 8080 98.190.71.2 8080 extendable
ip nat inside source static tcp 192.168.3.51 8081 98.190.71.2 8081 extendable

This may be needed for UDP traffic.

ip nat inside source static udp 192.168.3.50 8080 98.190.71.2 8080 extendable
ip nat inside source static udp 192.168.3.51 8081 98.190.71.2 8081 extendable
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.