1

I tried to disable auto-negotiation in my Juniper ACX-2200 , but it says

edit#set interfaces ge-0/1/0 gigaether-options no-auto-negotiation

raki@# commit 
[edit interfaces ge-0/1/0]
'gigether-options'
Autonegotiation shouldnt be disabled for Fiber media type
error: configuration check-out failed

The Documentation says I need to manually set the speed and duplex, I did set duplex to full deplex and speed to 1g both the sides, but it still gives me same error.

  • The fiber transceiver doesn't support negotiation. The speed and duplex are fixed. – Ron Maupin Dec 6 '16 at 14:43
  • @RonMaupin Well but link is fluctuating due to this, In cisco routers we have no problem disabling auto-negotiation in fiber transceiver. – R__raki__ Dec 6 '16 at 14:45
  • On a Cisco router, it may accept the speed and duplex command, but it doesn't actually do anything. Unlike UTP interfaces, you cannot actually change the speed and duplex of a fiber transceiver. If on the Cisco, you mean the switchport nonegotiate command, that is something altogether different. That simply disables DTP, and it has nothing to do with speed or duplex. – Ron Maupin Dec 6 '16 at 14:50
  • 2
    Fiber transceivers don't negotiate the speed or duplex. They are the speed and duplex for which they are manufactured. Some Cisco devices have SFP+ slots that can take either 10 Gbps or 1 Gbps fiber transceivers, but you get the speed of the transceiver you install. You cannot change the speed and duplex with a configuration command. – Ron Maupin Dec 6 '16 at 15:04
  • 2
    @JFL, yes, but the 1000BASE-T transceiver is not a fiber transceiver. The question is about fiber transceivers. – Ron Maupin Dec 6 '16 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.