2

This should be simple but I'm missing something. Setting up an ASA 5505 to replace an old Netgear router. Same external IP address and gateway. I'm not getting access to the internet from the inside. What am I missing? Thanks.

Result of the command: "show running-config"

: Saved
: 
: Serial Number: XXXXXXXXXXXX
: Hardware:   ASA5505, 512 MB RAM, CPU Geode 500 MHz
:
ASA Version 9.2(4)13 
!
hostname dommy
domain-name XXXXXXXX.com
enable password XXXXXXXXXXXXXX/m encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 2XX.198.XXX.250 255.255.255.248 
!
ftp mode passive
dns server-group DefaultDNS
 domain-name XXXXXXXX.com
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network 2XX.198.XXX.249
 host 2XX.198.XXX.249
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj_any
 nat (inside,outside) dynamic interface
!
nat (inside,outside) after-auto source dynamic any interface
route inside 0.0.0.0 0.0.0.0 2XX.198.XXX.249 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd address 192.168.0.20-192.168.0.50 inside
dhcpd dns 8.8.8.8 8.8.4.4 interface inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:56564d7342353trg628041c21f71f2965
: end
  • Can you re-submit your running configuration after Ron Trunk's configuration update? Also, check to make sure you have removed route inside 0.0.0.0 0.0.0.0 2XX.198.XXX.249 1 and replaced it with route outside 0.0.0.0 0.0.0.0 2XX.198.XXX.249 1. – TDurden Dec 8 '16 at 20:47
  • I will submit the new config in the morning. (There is a narrow window when I can make changes due to the production environment.) I have confirmed removal of the incorrect inside statement. Thanks for your help. – Greg Dec 8 '16 at 22:50
  • I'm not getting access to the internet from the inside. you're not basing that on failed pings are you? You're not inspecing ICMP so ALL pings from inside to outside WILL fail. – meccooll Dec 9 '16 at 1:20
  • It is working now. I restarted the ASA and the new corrected configuration (with the change from Ron Trunk) is working. – Greg Dec 9 '16 at 13:49
2
route inside 0.0.0.0 0.0.0.0 2XX.198.XXX.249 1

I believe you want this to say route outside

| improve this answer | |
  • Thank you. I changed that line (it now shows that) and still cannot get out. (I wr mem and reloaded the config.) – Greg Dec 8 '16 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.