2

I have ASA-5505 with public IP facing interface with port forwarding https/443 to a Barracuda SSL VPN appliance. (Barracuda has private ip only).

Running in L2 mode where remote hosts feel like they plugged into a switch next to this appliance.

When VPN appliance is on TCP mode, remote hosts can connect but fails at UDP mode. (Failure at TLS handshake where appliance can't reply back).

Anything wrong with my ACL and NAT rules? Thanks.

55ASA# show run
: Hardware:   ASA5505, 512 MB RAM, CPU Geode 500 MHz
:
ASA Version 9.2(4) 
!
hostname 55ASA
domain-name vpn.com
enable password
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd 
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!             
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 172.16.0.1 255.255.0.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 1.2.3.4 255.0.0.0 
!
interface Vlan3
 no nameif    
 no security-level
 no ip address
!
boot system disk0:/asa924-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 84.200.69.80
 name-server 8.8.8.8
 domain-name vpn.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network hostNW
 host 172.16.100.100
object network hostHTTP
 host 172.16.1.180
object network obj-172
 subnet 172.16.0.0 255.255.0.0
object service https-udp
 service udp source eq 443 destination eq 443 
object-group service DM_INLINE_SERVICE_1
 service-object object https-udp 
 service-object tcp destination eq https 
 service-object udp destination eq 443 
access-list inside_access_in extended permit ip object obj-172 any4 
access-list outside_access_in extended deny ip 10.0.0.0 255.0.0.0 any 
access-list outside_access_in extended deny ip 172.16.0.0 255.240.0.0 any 
access-list outside_access_in extended deny ip 192.168.0.0 255.255.0.0 any 
access-list host-acl extended permit object-group DM_INLINE_SERVICE_1 any object hostNW 
access-list host-acl extended permit tcp any object hostHTTP eq www 
pager lines 24
logging enable
logging buffer-size 987564
logging buffered informational
logging asdm informational
mtu inside 1500
mtu outside 1500
ip verify reverse-path interface inside
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-762-150.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network hostNW
 nat (inside,outside) static interface net-to-net service tcp https https 
object network hostHTTP
 nat (inside,outside) static interface service tcp www www 
object network obj-172
 nat (inside,outside) dynamic interface
!
nat (inside,outside) after-auto source dynamic any interface
access-group inside_access_in in interface inside
access-group host-acl in interface outside

route outside 0.0.0.0 0.0.0.0 4.3.2.1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL 
aaa authentication http console LOCAL 
aaa local authentication attempts max-fail 3
http server enable
http 172.16.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
no crypto isakmp nat-traversal
telnet timeout 5
ssh stricthostkeycheck
ssh 172.16.0.0 255.255.0.0 inside
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
no vpn-addr-assign local
no ipv6-vpn-addr-assign aaa
no ipv6-vpn-addr-assign local

dhcp-client client-id interface outside
dhcpd dns 84.200.69.80 8.8.8.8
dhcpd domain vpn.com
dhcpd update dns both override 
dhcpd option 3 ip 172.16.0.1
!
dhcpd address 172.16.1.100-172.16.1.130 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics host
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
ntp server 216.228.192.69 source outside
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol l2tp-ipsec 
username 55lt password FOFWAf8le0N1mWrv encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:ff597b145b695afa61ce3c60ae8cc8b9
: end
55ASA# 
  • What do your logs say when you use UDP? – Ron Trunk Dec 11 '16 at 21:53
  • On client: "TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)" in the OpenVPN log if is unable to connect to the remote VPN server." & On ASA, outbound 443/udp gets blocked whereas 443/tcp isn't. Any other log you are talking about? – opensourceworker Dec 12 '16 at 2:14
  • What is the specific message on the ASA when blocking 443 Udp? – Ron Trunk Dec 12 '16 at 2:55
  • It looks like you are only forwarding TCP/443, not UDP/433 to the server? – hertitu Dec 12 '16 at 10:13
  • RonTrunk, still trying to dig through "Show log" but showing the sessions tears down. hertitu, how would we accomplish UDP/443? – opensourceworker Dec 12 '16 at 15:47
2

B a r r a c u d a S S L V P N A d m i n i s t r a t o r ’ s G u i d e

enter image description here

0
object-group service DM_INLINE_SERVICE_1
 service-object udp destination eq 4444 
object network openNW-udp
 nat (inside,outside) static interface service udp 4444 4444

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.