1

I have added BGP to routing domain 0 on the BIG IP GUI using the AWS cloud BIG IP. however i cannot find out where to add my routing peers.

imish does not work tmsh does not work zebos does not work

Where do i specify the routing neighbors?

Thanks

admin@(ip-1 )(cfg-sync Standalone)(Active)(/Common)(tmos)# zebos enable bgp 
=== Protocols are no longer enabled or disabled with === 
=== this utility. Please use tmsh, gui or icontrol. ===

usage: zebos [-r <rd_id | -a] check zebos [-r <rd_id | -a] (cmd command1),command2]

admin@(ip-1 )(cfg-sync Standalone)(Active)(/Common)(tmos)# imish Dynamic routing is not enabled in route domain 0 
admin@(ip-1 )(cfg-sync Standalone)(Active)(/Common)(tmos)# imish ? 
admin@(ip-1 )(cfg-sync Standalone)(Active)(/Common)(tmos)# tmsh ? Syntax Error: unexpected argument "tmsh" 
admin@(ip-1 )(cfg-sync Standalone)(Active)(/Common)(tmos)# tmsh Syntax Error: unexpected argument "tmsh" 
admin@(ip-1 )(cfg-sync Standalone)(Active)(/Common)(tmos)#

the no commands seem to work, i just get the same message each time

admin@(ip-10-53-53-151)(cfg-sync Standalone)(Active)(/Common)(tmos)# run util zebos -r 0 check
=== route domain: 0 ===
No dynamic routing protocol enabled
admin@(ip-10-53-53-151)(cfg-sync Standalone)(Active)(/Common)(tmos)# run util zebos -r 0 bgp enable
Unknown command: bgp
usage: zebos [-r <rd_id | -a] check
       zebos [-r <rd_id | -a] (cmd command1)[,command2]

admin@(ip-10-53-53-151)(cfg-sync Standalone)(Active)(/Common)(tmos)# run util zebos -r 0 enable bgp
=== Protocols are no longer enabled or disabled with ===
=== this utility. Please use tmsh, gui or icontrol.  ===

usage: zebos [-r <rd_id | -a] check
       zebos [-r <rd_id | -a] (cmd command1)[,command2]

admin@(ip-10-53-53-151)(cfg-sync Standalone)(Active)(/Common)(tmos)#
2
  • You used AS 0? I seriously doubt you were assigned that, and the user-defied AS numbers start at 65000.
    – Ron Maupin
    Dec 19 '16 at 21:15
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 15 '17 at 16:46
1

The tmos in the prompt indicates that you are already inside the tmsh shell. No need to prefix commands with tmsh. You would only do this if you were in the bash shell (to get there from tmos, type run util bash). To get to the imish and zebos shells, you have to use run util imish or run util zebos

5
  • neither commands work, i just get the same message everytime
    – AlexW
    Dec 20 '16 at 9:52
  • Did you try "run util imish -r 0"? It should drop you into a shell similar to Cisco CLI
    – John K.
    Dec 20 '16 at 17:02
  • admin@(ip)(cfg-sync Standalone)(Active)(/Common)(tmos)# run util imish -r 0 Dynamic routing is not enabled in route domain 0
    – AlexW
    Dec 21 '16 at 14:49
  • Are you licensed for the Advanced Routing Module?
    – John K.
    Dec 22 '16 at 10:23
  • "Dynamic routing is not enabled in route domain 0" suggests you need to first enable BGP on route domain 0 in the admin web UI.
    – phs
    Nov 5 '18 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.