1

When calling cells in US sometimes our company number shows as blocked or restricted.

Our topology is

CUCM 9.1 <-> 2921 VG 15.2(4) <-> T1 PRI

Our telco advised to make sure we have parameters assigned to our PBX:

In order for caller ID number to be delivered to cell carriers these 3 calling parameters needs to be set in your PBX. It may work sometimes w/o these parameters but the only way to GUARENTEE CID number delivery to cells is if the PBX has these 3 parameters populated.

Nature of address indicator ANSI: Unique national (significant) number
Numbering plan indicator: ISDN (Telephony) numbering plan (Recommendation E.164)
Screening indicator: Reserved for ‘User Provided, Passed Network Screening’





These are your current settings in your PBX.

Calling party number parameter
Parameter name 10 Calling party number
Length indicator 7 $07
Odd even indicator 0 even
Nature of address indicator                            0
Spare 0 –
Numbering plan indicator                               0
Address presentation restricted indicator 0 presentation allowed
Screening indicator 1                                      user provided, screening passed
Address signals 618615098

debug isdn Q.931

    375718: Dec 21 17:53:09.016: %IPPHONE-6-REGISTER_NEW: ephone-29:SEP2C3F38C838FF IP:10.1.102.11 Socket:15 DeviceType:Phone has registered.
375719: Dec 21 12:53:52.068: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8 callref = 0x0B53
Bearer Capability i = 0x8090A2
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xA98381
Exclusive, Channel 1
Calling Party Number i = 0x0081, '6176140715'
Plan:Unknown, Type:Unknown
Called Party Number i = 0x80, '17816084388'
Plan:Unknown, Type:Unknown
375720: Dec 21 12:53:52.392: ISDN Se0/0/0:23 Q931: RX <- CALL_PROC pd = 8 callref = 0x8B53
Channel ID i = 0xA98381
Exclusive, Channel 1
375721: Dec 21 12:53:53.360: ISDN Se0/0/0:23 Q931: RX <- ALERTING pd = 8 callref = 0x8B53
Progress Ind i = 0x8488 - In-band info or appropriate now available
375722: Dec 21 12:54:22.529: ISDN Se0/0/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x0B53
Cause i = 0x8090 - Normal call clearing
375723: Dec 21 12:54:22.577: ISDN Se0/0/0:23 Q931: RX <- RELEASE pd = 8 callref = 0x8B53
375724: Dec 21 12:54:22.597: ISDN Se0/0/0:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x0B53
375725: Dec 21 17:55:49.661: %IPPHONE-6-UNREGISTER_NORMAL: ephone-29:SEP2C3F38C838FF IP:10.1.102.11 Socket:15 DeviceType:Phone has unregistered normally.

Gateway is configured as MGCP

config

interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn map address ^011 plan unknown type unknown
isdn bind-l3 ccm-manager
no cdp enable

ccm-manager fallback-mgcp 
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.10.10.10
ccm-manager config
!

mgcp
mgcp call-agent 10.10.10.10 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
mgcp default-package fxr-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
1

In the end we have configured it on the CUCM as it is a MGCP gateway and controlled from the server rather than gateway.

Now all calls pass full number and locality on both landlines and molife phones.

Our final settings after few hours of testing in the picture below:

enter image description here

0
0

There's 2 distinct parameters: calling number and calling name. They are not the same. Some PSTN providers allow you to set one or both of these to whatever you want, others will not.

Passing calling number should be trivial. There is a mask field in CM, as I recall. Don't mask outbound calls. Put "XXXX" in there rather than the main number. Note this setting may appear in the line configuration page and the route pattern page. ...It's been a while. Should be easy though. Just remember, your provider may not allow you to spoof / provide other numbers than your DID range.

As far as passing name goes, I believe your PSTN provider sets that for you and you would need to coordinate with them if you want something other than "" to show up for particular DID's.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.