1

The problem is: I can not find a QinQ(a.k.a. double vlan tagging or dot1q tunnel) feature in the following cisco switch: WS-C4510R+E, SUP8-E with WS-X4748-UPOE+E line card installed.

The Cisco Feature Navigator says it should be in my platform.

I'm pretty new at the IOS-XE, the only IOS supported by this HW.

I've upgraded ios-xe to the: cat4500es8-universalk9.SPA.03.08.01.E.152-4.E1.bin And also I've tried: cat4500es8-universal.SPA.03.03.00.XO.151-1.XO.bin cat4500es8-universalk9.SPA.03.09.01.E.152-5.E1.bin No luck.

May be I have some license or feature enable(mechanism) in IOS-XE Problem. My current license looks like:

Switch#show license all 
License Store: Primary License Storage
License Store: Dynamic License Storage
StoreIndex: 0 Feature: entservices  Version: 1.0
      License Type: Evaluation
        Evaluation total period: 8 weeks 4 days 
        Evaluation period left: 8 weeks 3 days 
      License State: Inactive
      License Count: Non-Counted
      License Priority: Low
StoreIndex: 1 Feature: entservices  Version: 1.0
      License Type: PermanentRightToUse
      License State: Active, Not in Use, EULA accepted
      License Count: Non-Counted
StoreIndex: 2 Feature: ipbase  Version: 1.0
      License Type: Evaluation
        Evaluation total period: 8 weeks 4 days 
        Evaluation period left: 8 weeks 4 days 
      License State: Inactive
      License Count: Non-Counted
      License Priority: None
StoreIndex: 3 Feature: ipbase  Version: 1.0
      License Type: PermanentRightToUse
      License State: Active, Not in Use, EULA accepted
      License Count: Non-Counted
StoreIndex: 4 Feature: lanbase  Version: 1.0
      License Type: PermanentRightToUse
      License State: Active, Not in Use, EULA accepted
      License Count: Non-Counted
StoreIndex: 5 Feature: apcount  Version: 1.0
      License Type: Evaluation
        Evaluation total period: 8 weeks 4 days 
        Evaluation period left: 8 weeks 4 days 
      License State: Active, Not in Use, EULA not accepted
      License Count: 0/0
      License Priority: None
StoreIndex: 6 Feature: apcount  Version: 1.0
      License Type: PermanentRightToUse
      License State: Inactive
      License Count: 0/0

I haven't find the sdm template command there also.

Switch#show dot1? 
dot1x  

First of all i've tried to:

configure terminal
    int gi 1/1
    (config-if)#swi mode ?
          access        Set trunking mode to ACCESS unconditionally
          dynamic       Set trunking mode to dynamically negotiate access or trunk mode
          private-vlan  Set private-vlan mode
          trunk         Set trunking mode to TRUNK unconditionally
    (config-if)#int te 5/5
    (config-if)#swi mode ?
          access        Set trunking mode to ACCESS unconditionally
          dynamic       Set trunking mode to dynamically negotiate access or trunk mode
          private-vlan  Set private-vlan mode
          trunk         Set trunking mode to TRUNK unconditionally

And nothing about:

switchport mode dot1q-tunnel

and even

show dot1q?
% Unrecognized command

Because I'm not setting up QinQ in the first time. I've checked at Cisco Feature Navigator to be sure my IOS-XE supported it. Yes cat4500es8-universalk9.SPA.03.08.01.E.152-4.E1.bin supports QinQ and even Selective QinQ. I've tried to configure QinQ at line-card and SUP8-E - no such command.

    (config)#default int te5/5
    Interface TenGigabitEthernet5/5 set to default configuration
    (config)#int te 5/5
    (config-if)#switchport 
    (config-if)#switchport mode access 
    (config-if)#switchport access vlan 10
    (config-if)#switchport nonegotiate 
    (config-if)#switchport mode ?
          access        Set trunking mode to ACCESS unconditionally
          dynamic       Set trunking mode to dynamically negotiate access or trunk mode
          private-vlan  Set private-vlan mode
          trunk         Set trunking mode to TRUNK unconditionally



    (config)#default int te5/5
    Interface TenGigabitEthernet5/5 set to default configuration
    (config)#int te 5/5
    (config-if)#switchport 
    (config-if)#switchport mode access 
    (config-if)#switchport access vlan 10
    (config-if)#switchport nonegotiate 
    (config-if)#switchport mode ?
          access        Set trunking mode to ACCESS unconditionally
          dynamic       Set trunking mode to dynamically negotiate access or trunk mode
          private-vlan  Set private-vlan mode
          trunk         Set trunking mode to TRUNK unconditionally
    (config-if)#switchport vl?
          % Unrecognized command

I think the main problem is Inactive ent license:

StoreIndex: 0 Feature: entservices  Version: 1.0
      License Type: Evaluation
        Evaluation total period: 8 weeks 4 days 
        Evaluation period left: 8 weeks 3 days 
      License State: Inactive
      License Count: Non-Counted
      License Priority: Low
  • What have you tried to enable QinQ on a switch interface, e.g. switchport mode dot1q-tunnel? – Ron Maupin Dec 24 '16 at 19:02
  • I'm asking for what you have tried. You don't show that in your question. Please edit your question to show what you have tried. – Ron Maupin Dec 24 '16 at 19:58
  • Sure I've tried it. No such command for line card (int gi1/1) and SUP8-E(Int Te5/5). IOS-XE doesn't even understand show dot1q ? – Pavel Dec 24 '16 at 20:23
  • That command was an example. What all have you tried? Edit your question to include everything you have tried, and any messages that arise from your attempts. You need to give us everything. – Ron Maupin Dec 24 '16 at 20:25
  • Edited. Sorry for the delay. – Pavel Dec 24 '16 at 20:36
3

As QinQ is ISP feature the key was in Not in Use entservice license state:

show license all
...
StoreIndex: 1 Feature: entservices  Version: 1.0
    License Type: PermanentRightToUse
    License State: Active, Not in Use, EULA accepted
    License Count: Non-Counted
...
#configure terminal
    #(config)#license boot level entservices !
#reload

Just After reload(No license were entered!):

show license all
    ...
    StoreIndex: 1 Feature: entservices  Version: 1.0
    License Type: PermanentRightToUse
    License State: Active, In Use
    License Count: Non-Counted
    ...
show log
    ...
    *Dec 26 01:20:03.606: %C4K_IOSSYS-6-IMAGELEVEL: Supervisor booting in image level 'entservices'
    ...

All commands needed for QinQ feature(and much more) became available:

#show dot1q-tunnel ?
    interface  specify an interface
    |          Output modifiers
    <cr>
(config)#int gi 1/1
    (config-if)#switchport mode ?
    access        Set trunking mode to ACCESS unconditionally
    dot1q-tunnel  set trunking mode to TUNNEL unconditionally
    dynamic       Set trunking mode to dynamically negotiate access or trunk mode
    private-vlan  Set private-vlan mode
    trunk         Set trunking mode to TRUNK unconditionally

By the way, all interface configuration commands are available in any switchport mode, just error can occurs:

(config)#int gi 1/1
    (config-if)#no switchport
    (config-if)#switchport mode dot1q-tunnel 
        Command rejected: Te5/5 is not a switching port.

And all show command available:

#show dot1q-tunnel 
    dot1q-tunnel mode LAN Port(s)
    -----------------------------
    Gi1/24
    Te5/5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.