2

I've just started my Cisco Router 886VA with factory settings. I am willing to assign port FastEthernet 0 to an IP address. This port is connected to my laptop which acts as a NAT between the router and the Cisco machine. All FastEthernet ports are assigned to VLAN1 (by default), and when I try to assign the IP address, I get the error:

% IP addresses may not be configured on L2 links.

Why is that happening?


Update:

Well, it is still not working.

Again: my settings are like the following: FastEthernet3 is connect to another home router, i should retrieve an IP address per DHCP which is working (192.168.1.8). I assigned this port to VLAN3 and this should be NAT ouside since i want to NAT from VLAN3 to VLAN1. Now, i setup a DHCP pool 192.168.100.1 for 3 the other 3 ports: FastEthernet 0-2, they are assigned to VLAN1, which is NAT inside.

I am not becoming connection on my computer which is connected to FastEthernet 1 (but still having an address from the pool). what shall i do?

Debugging info: NAT translation is failing !!!

So altogether, i am trying to enable NAT between VLAN1 (inside) to VLAN3 (outside)

Why am not able to connect or at all ping the home router???

Would be thankful for any help!

Here are my configuration:

Building configuration...

Current configuration : 1689 bytes
!
! Last configuration change at 23:24:01 UTC Thu Jan 5 2017
version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname x
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$34LK$ekdCKQuEmravI.qziPae7.
enable password xxxxxx!
!
no aaa new-model
memory-size iomem 10
!
!
!         
!
!
!


!
ip dhcp excluded-address 192.168.100.210 192.168.100.253
ip dhcp excluded-address 192.168.100.1 192.168.100.50
!
ip dhcp pool LAN
 network 192.168.100.0 255.255.255.0
 default-router 192.168.100.1 
 dns-server 8.8.8.8 
!
!
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!         
!
!
!
!
!
!
controller VDSL 0
!
! 
!
!
!
!
!
!
!
!
interface Ethernet0
 no ip address
 no ip route-cache
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
 isdn termination multidrop
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 description Extern-Router
 switchport access vlan 3
 no ip address
!
interface Vlan1
 description inside
 ip address 192.168.100.1 255.255.255.0
 no ip redirects
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1412
!
interface Vlan3
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
!         
control-plane
!
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password xxxxxxxxxxxxxx
 login
 transport input all
!

It is still not working, in other words sh ip nat translations still show nothing!


Update:

Wow it works - thank you alot !!!

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 15 '17 at 16:55
4

Your router has a switch module. The interfaces of the switch module are not router interfaces, and they cannot be assigned IP addresses they way you do with router interfaces.

With the switch interfaces you need to assign VLANs, and you can create SVIs (Switch Virtual Interfaces) to which you assign IP addresses. For instance:

interface Vlan1
 ip address 10.0.0.1 255.255.255.0
 no shutdown

The SVI will define the gateway address for your VLAN.


Edit for your update:

You have not enabled NAT. Yes, you have the ip nat inside and ipnat outside commands on the interfaces, but you have not created an ACL for the interesting traffic, nor have you enabled NAT on the router. That would look something like:

ip nat inside source list 10 interface Vlan3 overload
!
access-list 10 permit 192.168.100.0 0.0.0.255
  • And then : Conf t, int fas 0, switchport access vlan 1 – psniffer Dec 29 '16 at 17:25
  • Yes, but the question says, "All FastEthernet ports are assigned to VLAN1," so that seems unnecessary. – Ron Maupin Dec 29 '16 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.