1

Hi I´m having problems with telnet through NAT Load Balancing.

Always return when i try to do telnet 192.168.192.100 80: Destination unreachable; gateway or host down

enter image description here

ROUTER NAT config:

Current configuration : 1366 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname NAT
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.1.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.192.4 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
ip alias 192.168.192.100 23
!
ip nat pool APACHE_LIST 176.16.1.1 176.16.1.3 prefix-length 24 type rotary
ip nat inside destination list LOADBALANCE pool APACHE_LIST
!
!
ip access-list extended LOADBALANCE
 permit tcp any host 192.168.192.100 eq www
 permit tcp any host 192.168.192.100 eq telnet
no cdp log mismatch duplex
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

In WWW routers the only configuration I´ve done was assign ip to the interface and activate ip http server and activate VTY Lines

Thanks for your time

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 15, 2017 at 16:53

1 Answer 1

2

You have a few errors in your configuration that I have spotted. There may be more issues with how you have configured NAT.

interface FastEthernet0/0
 ip address 172.16.1.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto

ip nat pool APACHE_LIST 176.16.1.1 176.16.1.3 prefix-length 24 type rotary

The subnet assigned to your interface FastEthernet 0/0 does not match your inside local address pool. (172.16.1.0/24 vs 176.16.1.0/24)

NAT(config)#ip alias 192.168.192.100 23
Invalid IP address

Issue a no ip alias 192.168.192.100 23 command.

You also may want to change your duplex and speed settings. I think that you will find the interface to be operating at half-duplex if you issue a show int fa 0/0 | in duplex command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.