I have a EdgeMax Router X and I got the basic to work. The subnet for the default is

My wifi access points have the option for guest networks. Those however are on a seperate subnet

This didn't seem like a problem to me but the 179 subnet doesn't seem to be getting internet access.

Who should I give the 179 subnet internet access? In doing so will it also be able to communicate with the 178?

I tried to add a manual ip to the 'switch0' interface in my router (so both 178 and 179 are configured there) but it doesn't seem to work.

Thanks in advance


diagram table

  • Please post the configuration of your router. you will likely have to configure VLAN trunking on your router for the guest network.
    – Ron Trunk
    Commented Jan 6, 2017 at 12:29
  • Not sure how to post any. It hasn't got much configuration yet. Basically only a DHCP for and a switch interface.
    – John
    Commented Jan 6, 2017 at 13:33
  • You can edit your post to insert it. Use the "preformatted" text option.
    – Ron Trunk
    Commented Jan 6, 2017 at 13:38
  • What configuration(s) would you like to see?
    – John
    Commented Jan 6, 2017 at 13:40
  • All of it. especially the interface and vlan configurations. We also need to know more about your access point configuration.
    – Ron Trunk
    Commented Jan 6, 2017 at 13:41

1 Answer 1


The details of what you need to do are too involved for a post here, but these are the high level steps:

  1. Create two VLANs on your switch- one for users and one for guests
  2. Create a trunk port on the link between your switch and router to tag the VLANs
  3. Create subinterfaces on your router-- one for each VLAN: 178 and 179
  4. Create a new DHCP scope for your guest network
  5. Apply an access control list on your router to block guests from reacing your internal network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.