1

i have this setup which is a bit low end because i ran out of test server to test so i'm just doing what i can to attain target setup. Normally i would use a blade or rack type server.

So my setup normally in a rack type server would have a 4 Ethernet port but on a desktop type machine it only has 1 so what i did to have a sort of 4 Ethernet port is have it setup as VLAN, (eth1.100, eth2.100, etc) and connected it to a 2950 cisco switch. I configured the ports connected to the machine as trunk so all VLANS will pass through it. As to why i need these vlan is because i need 4 ports which is a limitation to a desktop type machine (buying is an NIC 4 port is not an option so i will stick to this setup).

Now, my problem is i cannot ping 1.1.1.1 in PC0 to 1.1.1.2 in PC1, even though i have already configured those ports to trunk. See picture below to have a more understandable setup. Also, i have read that when you configure a VLAN / sub-interface, physical port would be automatically on trunk mode

enter image description here

What am i doing wrong?

By the way as an added info, i tested this to a normal switch (not managed, just a normal household switch and i got a successfull ping)

Just so everyone will know, i cannot test my setup on a packet tracer since i cannot configure a VLAN (subinterface) on a PC machine in packet tracer, the picture above is only to have everyone a clear view on my setup. Logs, setup, configuration is not available since its isolated.

UPDATES:

sw1#show interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1
Fa0/2       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1-1005
Fa0/2       1-1005

Port        Vlans allowed and active in management domain
Fa0/1       1,100
Fa0/2       1,100

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,100
Fa0/2       1,100

sw1#

sw1#show interfaces fa0/1
FastEthernet0/1 is up, line protocol is up (connected)
  Hardware is Lance, address is 0030.a311.5301 (bia 0030.a311.5301)
 BW 100000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     956 packets input, 193351 bytes, 0 no buffer
     Received 956 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     2357 packets output, 263570 bytes, 0 underruns
     0 output errors, 0 collisions, 10 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
sw1#show interfaces fa0/2
FastEthernet0/2 is up, line protocol is up (connected)
  Hardware is Lance, address is 0030.a311.5302 (bia 0030.a311.5302)
 BW 100000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     956 packets input, 193351 bytes, 0 no buffer
     Received 956 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     2357 packets output, 263570 bytes, 0 underruns
     0 output errors, 0 collisions, 10 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
sw1#

sw1#show interfaces switchport 
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none

Name: Fa0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
  • 1
    If you don't share your configuration, we can only guess. My best guess would be that you've configured the switchports without a native VLAN and your PCs expect untagged ethernet frames. So configure a native VLAN on those ports. If that doesn't help, please just include the configuration statements for that switch. – Teun Vink Jan 14 '17 at 10:08
  • which configuration would you like to see? btw what you do mean by untagged? i have the switch restored to factory settings and only set Ports 1-8 as trunk using command "switchport mode trunk" thats the only thing i did on the switch – lemoncodes Jan 14 '17 at 10:16
  • 1
    Why are you setting it to mode trunk if you have no idea what tagging is? Please just include the switch configuration. – Teun Vink Jan 14 '17 at 10:19
  • what i meant by what is untagged is that why do i need native VLAN for?, as what i understand trunk ports allow all VLANS? or maybe there are lacking info?.. see updated post, that is the best i could get, some of it is not allowed anymore sorry tell me what else config do you need – lemoncodes Jan 14 '17 at 10:30
  • I never understand why people seeking help here simply refuse to provide the necessary information to help them. Why will you simply not provide your switch configuration as was asked for twice already? That is what we need to look at. If you don't provide that, don't expect to get a correct answer to your question. Help us help you. – Ron Maupin Jan 14 '17 at 17:46
2

First of all, having one port with sub-interfaces in different VLANS is not the same thing as having four ports. Having a machine with that many NICs in different VLANs is generally a bad idea. As a network guy, I don't trust the server to know what interface it should be sending traffic out. In your scenario, can you say for sure which NIC the original ping request is coming out of? If it's not eth1.100 every time, the ping will fail. It could also fail if it goes out eth1.100 and when it's received by PC1 that machine sends the reply out any interface other than eth1.100.

You could use a wireshark capture on the machines to look for where the packets are coming/going.

do a show mac address-table on the switch and look to see which VLAN the mac addresses are showing as being on. Although, with your config this could change at the will of the PCs.

From your output, only VLAN 100 is actually being trunked to the two PCs. So you are missing 200, 300, and 400. Verify that those VLANs are created on the switch with show vlan.

  • oh you mean to say i have to create vlans 100,200,300,400 even though i will not actually use them ( make ports member of them)? i am not assigning vlan tags on all ports but only trunk some ports fa0/1-8 – lemoncodes Jan 15 '17 at 1:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.