2

We have a SonicWALL NSA 220 running SonicOS Enhanced 5.8.1.2-20o. Our ISP provides a symmetrical 100/100 ethernet handoff. Performance on the ingress achieves the full 100Mbps while egress only achieves ~30-40Mbps. What am I not considering in troubleshooting this? Is there anything that might cause this type of asymmetry in performance?

Here is what I have done so far:

• Disabled auto-negotiation on WAN interface and coordinated hard coded 100/Full Duplex setting on ISP gateway

• Confirmed MTU is 1500 bytes on all devices on the local ethernet

• Confirmed MTU is 1500 bytes on firewall and ISP gateway and ISP next hop

• Confirmed all services are disabled on SonicWall (including CFS, DPI, BWM, LB, etc.) - it is pretty much just running a stock configuration minus some port forwarding rules

• Observed high CPU utilization (65%-95% for periods in excess of 10 minutes under a relatively light load 58 connections)

2
  • 1
    What is your testing methodology that is giving you these speed results? Have you tried hooking a computer directly to the ethernet handoff and see what kind of results you get? Oct 31, 2013 at 20:45
  • Sorry - I should have clarified, performance direct form the ethernet handoff is 100/100 - no performance degradation. I have done testing using jperf and web based "speed tests."
    – sardean
    Oct 31, 2013 at 22:57

2 Answers 2

4

The issue was resolved by updating the firmware. Firmware was updated to 5.9.x.

0
1

You can try following things,

  1. Disable IPS on ZONEs (LAN and WAN).
  2. Connect a laptop directly to WAN, have public IP and do a speed test and verify.
  3. Have a dummy Switch between your sonicwall and ISP modem.(mostly resolves the issue).
2
  • 1. IPS is disabled, 2. Speed when directly connected to ethernet handoff is exactly as expected, 3. Can you elaborate on your third point?
    – sardean
    Oct 31, 2013 at 22:59
  • Connect X1(WAN) interface port of sonicwall to a Switch(fast Ethernet or gigabit Switch) and also connect the cable coming from ISP to the same Switch. make sure to have "auto-negotiate" on sonicwall WAN interface and ISP router interface. ISP router interface and sonicwall WAN interface negotiation could be the problem, having a Switch between them mostly resolves the issue by negotiating between sonicwall and ISP router.
    – user31198
    Nov 1, 2013 at 2:01

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .