1

Is there a way to interconnect VLANs using this diagram?

MLS0 has this configuration:

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk

And SW0:

interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 175
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 176
 switchport mode access
!
interface FastEthernet0/4
 switchport mode trunk`

enter image description here

2 Answers 2

2

To get traffic from one VLAN to another VLAN, you need to use a router. The layer-3 switch could be used as a router. The hosts connected to each VLAN would use the SVI on the layer-3 switch for it VLAN as the gateway.

ip routing
!
interface Vlan175
 ip address 10.175.0.1 255.255.255.0
 no shutdown
!
interface Vland176
 ip address 10.176.0.1 255.255.255.0
 no shutdown
!

The PCs on VLAN 175 would use 10.175.0.1 as their gateway, and the PCs on VLAN 176 would use 10.176.0.1 as their gateway.


With two layer-3 switches (routers) you could use a FHRP (First Hop Redundancy Protocol), e.g. HSRP, to create a virtual gateway that the PCs use as their gateway, and the real routers will decide which is the active gateway, but will automatically fail over in the event of a router failure.

2
  • Thanks for replaying. I'm already using SVI on the layer-3 switchs for gateway for gateway purpose, but I don't gave connection. Jan 16, 2017 at 23:51
  • @LuisAdriánTobar Did you set the host's default gateway as the SVI address for their respective VLAN? Check out this link for additional information on using and configuring L3 switches.
    – Eddie
    Jan 17, 2017 at 1:15
0

To ensure connectivity between Different Vlan . Routing has to be done between both Vlans , Layer3 device is required for Configuring routing between Vlans . In router inter-Vlan routing need to be done to ensure connectivity between two Vlans by Configuring inter-Vlan routing .

In layer3 switch Switch virtual interfaces(SVI) need to be configured and enable" ip routing "

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.