1

I have been tasked to build a network on PT which involves 4 subnets and they are all connected via one router using serial cables any ideas on how i can do it. That one router is acting as the internet in this case.

3
  • 1
    The network that i have built has a router in the middle and then 4 other routers coming off that using serial cables but as for ip addresses i cant seem to get them to pin from one subnet to another Jan 17 '17 at 21:55
  • 1
    Are the interfaces up? Is clocking set on DCE interfaces? Did you set IPs and subnet masks on all your interfaces? Is routing enabled? Did you set routes statically or are you using a dynamic protocol? Post a diagram; post the configs, then maybe we can help you a bit. Jan 17 '17 at 22:45
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 15 '17 at 18:56
2

Network Diagram

There are a number of ways to do this, this is a rather basic solution

If you want the pt file let me know. Here is a very rough way on how to do it using EIGRP

Here are the configs for the routers:

Net 1

en
conf t
Hostname Net_1 

int fa0/0
ip addr 192.168.1.1 255.255.255.0
no shut

int s0/0/0
ip addr 192.168.5.2 255.255.255.252
no shut

exit
Router eigrp 1
no auto-summary
network 192.168.5.0 0.0.0.3
network 192.168.1.0 0.0.0.255

end
wr

Net 2

en
conf t
Hostname Net_2

int fa0/0
ip addr 192.168.2.1 255.255.255.0
no shut

int s0/0/0
ip addr 192.168.5.6 255.255.255.252
no shut

exit
Router eigrp 1
no auto-summary
network 192.168.5.4 0.0.0.3
network 192.168.2.0 0.0.0.255

end
wr

Net 3

en
conf t
Hostname Net_3

int fa0/0
ip addr 192.168.3.1 255.255.255.0
no shut

int s0/0/0
ip addr 192.168.5.10 255.255.255.252
no shut

exit
Router eigrp 1
no auto-summary
network 192.168.5.8 0.0.0.3
network 192.168.3.0 0.0.0.255

end
wr

Net 4

en
conf t
Hostname Net_4

int fa0/0
ip addr 192.168.4.1 255.255.255.0
no shut

int s0/0/0
ip addr 192.168.5.14 255.255.255.252
no shut

exit
Router eigrp 1
no auto-summary
network 192.168.5.12 0.0.0.3
network 192.168.4.0 0.0.0.255

end
wr

Gateway

en
conf t
Hostname Gateway

Int lo0
description Internet
ip addr 89.55.47.33 255.255.255.252

int s0/0/0
ip addr 192.168.5.1 255.255.255.252
clock rate 64000
bandwidth 64
no shutdown

int s0/0/1
ip addr 192.168.5.5 255.255.255.252
clock rate 64000
bandwidth 64
no shutdown

int s0/1/0
ip addr 192.168.5.9 255.255.255.252
clock rate 64000
bandwidth 64
no shutdown

int s0/1/1
ip addr 192.168.5.13 255.255.255.252
clock rate 64000
bandwidth 64
no shutdown


Router eigrp 1
no auto-summary
Network 192.168.5.0 0.0.0.3
Network 192.168.5.4 0.0.0.3
Network 192.168.5.8 0.0.0.3
Network 192.168.5.12 0.0.0.3
redistribute static
exit

ip route 0.0.0.0 255.255.255.255 Lo0

end

wr
0

You can design your network as per your requirement depends upon devices used in setup

Option 1 : Using router and layer2 switches

Configure inter-Vlan routing between four subnets in router by creating sub -interfaces

Example

Router(config)#int F0/0

Router(config)#no ip address

Router(config)# no shutdown

Router(config)# int f0/0.3

Router(config)#ip address X.X.X.X 255.X.X.X

Router(config)#encapsulation dot1 3

Router(config)# no shutdown

Futher connect layer2 with this interface and Configure trunk port at switch end allowing all Vlans

Option 2

Used layer 3 and layer2 switches

Configure Switch virtual interfaces(SVI) in layer3 switch and connect access switch Configuring trunk port at layer3 switch and access switch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.