1

I tried to configure my router to use NTP server. I thought it is trivial but I was wrong. It causes a very nasty problem when router have yet to gain internet access (during boot).

I see the following message printed on the console.

Translating "1.pool.ntp.org"...domain server (255.255.255.255)

Translating "2.pool.ntp.org"...domain server (255.255.255.255)

Translating "2.pool.ntp.org"...domain server (255.255.255.255)

Translating "0.pool.ntp.org"...domain server (255.255.255.255)

It seems those DNS resolutions actually blocks the router from booting into the login prompt. It adds minutes to the boot time and prevents some config from being applied.

How can I prevent the DNS lookup from blocking the router? I searched on the "Translating" topic but they all refers to handling typos which is not the problem I faced.

Are there trustworthy NTP servers similar to Google's 8.8.8.8 which I can point to without doing DNS resolution?

1
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 7 '17 at 20:02
1

First, you need to turn off domain lookup

no ip domain-lookup

Then, you need to specify your NTP servers by IP address, rather than by name. You could manually resolve the ntp.org server names and use those addresses. Two addresses ought to be fine, unless you are doing something with your router that requires very accurate time. But for logging purposes, it only matters that your devices are all synced to the same time source. The absolute accuracy isn't important.

2
  • With all due respect, if I specify NTP server by IP, I would not need to turn off ip domain-lookup. Besides, turning off ip domain-lookup will break a lot of things.
    – some user
    Jan 22 '17 at 2:07
  • Ok. If you need it, leave it enabled.
    – Ron Trunk
    Jan 22 '17 at 2:08
0

It seems those DNS resolutions actually blocks the router from booting into the login prompt. It adds minutes to the boot time and prevents some config from being applied.

That is not preventing you from booting to the login prompt, it is preventing the router from presenting the login prompt. The router is still booting, and it doesn't really add any time to the boot process, it just seems that way.

How can I prevent the DNS lookup from blocking the router?

It is not actually blocking the router.

Are there trustworthy NTP servers similar to Google's 8.8.8.8 which I can point to without doing DNS resolution?

Yes. Unfortunately such recommendations are explicitly off-topic here. Such a recommendation may become obsolete, and this site is meant as an archive. Also, specific IPv4 addresses will not work if you change to IPv6.

1
  • "The router is still booting, and it doesn't really add any time to the boot process". I beg to differ. I only see the interfaces coming online after the Press RETURN to get started! msg. I even added a EEM script and it too will not execute until after the msg. Without the ntp configs, the router boot up 2 minutes earlier. The DNS resolution of ntp servers is slowing down the boot.
    – some user
    Feb 1 '17 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.