2

I'm coming to terms with JunOS, and I have set up a lab that includes two SRX210s. I have set ge-0/0/1 on both devices to:

ge-0/0/1 {
unit 0 {
    family inet {
        address 20.0.0.1/24;
    }
}

.1 on SRX1 and .2 on SRX2. Because they are directly connected and on the same subnet, a route should be visible, but when I perform a show route, I don't see anything. Perhaps I am missing something here? Am I making some stupid, rookie mistake that I will later be forced to kick myself over?

Further details: Not even learning a mac over these interfaces, but I do if I use family ethernet-switching instead.

Thanks to anyone with any idea!

4

In junos it is not enough to just assign IP to the interface to be functional , for interface to be pinable you need to do the below :

  1. assign the interface for security zone : EX: set security zones security-zone untrust interfaces ge-0/0/1.0
  2. you have to enable ping in the security zone : EX: set security zones security zone host inbound traffic system services ping
| improve this answer | |
  • That's what I was missing. I tried to delete the whole security section at the start as I didn't want the srx to function as a firewall. Thanks! – Dmitriy Feb 6 '17 at 17:16
  • If you want to run SRX as a router you need to change it to packet mode, so you have to delete all the security configuration and run below command: set security forwarding-options family mpls mode packet-based and then commit – Mr.lock Feb 9 '17 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.