2

I'm trying to configure the forwarding of my router model CISCO 2801, which has ip publishes 201.236.137.xxx. For this, I am using the following command: ip nat inside source static ... What I want to do is run a virtual server on my computer that is inside the network with ip 192.168.3.11 on port 7001.

I have done it in the following way:

ip nat inside source static tcp 192.168.3.11 7001 201.236.137.xxx 80

So when I make a request from outside to the ip publishes 201.236.137.xxx I intend to see my server. I have not had success doing this.

To check the operation, I used the command show ip nat translation, and I can not find the configuration that I did. I only see others configurations that I have not done, like the following

Router#show ip nat translation

Pro Inside global      Inside local       Outside local      Outside global
tcp 201.236.137.156:1052 192.168.3.11:1052 64.233.190.84:443 64.233.190.84:443
tcp 201.236.137.156:1053 192.168.3.11:1053 188.172.192.3:5938 188.172.192.3:5938
tcp 201.236.137.156:1057 192.168.3.11:1057 23.96.38.64:443   23.96.38.64:443
tcp 201.236.137.156:1065 192.168.3.11:1065 190.98.163.146:80 190.98.163.146:80
tcp 201.236.137.156:1066 192.168.3.11:1066 64.233.190.94:80  64.233.190.94:80
tcp 201.236.137.156:1071 192.168.3.11:1071 64.233.190.94:443 64.233.190.94:443
tcp 201.236.137.156:1074 192.168.3.11:1074 64.233.190.113:443 64.233.190.113:443
tcp 201.236.137.156:1075 192.168.3.11:1075 64.233.190.95:443 64.233.190.95:443
tcp 201.236.137.156:1078 192.168.3.11:1078 64.233.190.101:443 64.233.190.101:443
tcp 201.236.137.156:1079 192.168.3.11:1079 64.233.190.84:443 64.233.190.84:443
tcp 201.236.137.156:1080 192.168.3.11:1080 64.233.190.94:443 64.233.190.94:443
tcp 201.236.137.156:1082 192.168.3.11:1082 64.233.190.99:443 64.233.190.99:443
tcp 201.236.137.156:1083 192.168.3.11:1083 64.233.190.132:443 64.233.190.132:443
tcp 201.236.137.156:1084 192.168.3.11:1084 64.233.190.94:443 64.233.190.94:443
tcp 201.236.137.156:1085 192.168.3.11:1085 216.58.212.131:443 216.58.212.131:443
tcp 201.236.137.156:1086 192.168.3.11:1086 64.233.190.94:443 64.233.190.94:443
tcp 201.236.137.156:1087 192.168.3.11:1087 82.165.143.100:80 82.165.143.100:80
tcp 201.236.137.156:1088 192.168.3.11:1088 64.233.186.154:80 64.233.186.154:80
tcp 201.236.137.156:1089 192.168.3.11:1089 82.165.143.100:80 82.165.143.100:80
tcp 201.236.137.156:1090 192.168.3.11:1090 82.165.143.100:80 82.165.143.100:80

....

Complete Router Configuration

router# configure terminal
router(config) #interface fastethernet 0/0
router(config-if) # ip address 192.168.3.1 255.255.255.0
router(config-if) # no shutdown
router(config) #interface fastethernet 0/1
router(config-if) # ip address 201.236.137.xxx 255.255.255.248
router(config-if) # no shutdown
router(config) #service dhcp
router(config) #ip dhcp pool RED1
router(dhcp-config) #network 192.168.3.1 255.255.255.0
router(dhcp-config) #default-router 201.236.137.153
router(dhcp-config) #dns-server 8.8.8.8
router(dhcp-config) #dns-server 8.8.4.4
router(config) #ip dhcp excluded-address 192.168.3.1 192.168.3.10
router(config) #access-list 10 permit 192.168.3.1 0.0.0.255
router(config) #ip nat inside source list 10 interface f0/1 overload
router(config) #interface f0/0
router(config-if) #ip nat inside
router(config-if) #exit
router(config) #interface f0/1
router(config-if) #ip nat outside
router(config-if) #exit
router(config) #ip route 0.0.0.0 0.0.0.0 f 0/1

Show Running Configuration

Router#show running-config
Building configuration...
Current configuration : 1198 bytes
!
! Last configuration change at 18:19:54 UTC Tue Feb 7 2017
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
!
!
ip dhcp excluded-address 192.168.3.1 192.168.3.10
!
ip dhcp pool RED1
network 192.168.3.0 255.255.255.0
default-router 201.236.137.153
dns-server 8.8.4.4
!
!
ip cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO2801 sn FTX151501M2
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 201.236.137.xxx 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
ip nat inside source list 10 interface FastEthernet0/1 overload
ip nat inside source static tcp 192.168.3.11 7001 201.236.137.156 80      extendable
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
access-list 10 permit 192.168.3.0 0.0.0.255
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Why do I see this? Any idea why my forwarding does not work and other configurations appear? Please help

Thank you very much

5
  • Please post your full router configuration. There are other commands we can't see. You can edit your original question
    – Ron Trunk
    Feb 7 '17 at 18:34
  • I added the full router configuration to the post Feb 7 '17 at 18:42
  • 1
    Please post the config from "show running-configuration" I don't see your static NAT in the config.
    – Ron Trunk
    Feb 7 '17 at 18:45
  • I posted the show running-config Feb 7 '17 at 19:02
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide your own answer and accept it.
    – Ron Maupin
    Aug 7 '17 at 0:42
1

Probably your server getting wrong default-gateway according to your DHCP-pool settings. Change your default-router to 192.168.3.1 in ip dhcp pool RED1

0

NAT is bidirectional but maybe try on outside interface:

ip nat outside source static tcp 201.236.137.156 80 192.168.3.11 7001       extendable

and than confirm if is working with:

# show ip nat translations

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.