1

We have a Cisco router (887VA) supplied by a 3rd party. The supplier says its switch ports are simply untagged/access-mode. However our HP switch, which is connected to the Cisco router's switch through a port on the HP switch (j9772a), which untagged/access-mode refuses to work correctly.

We have verified that a laptop which directly connects to either the Cisco or the HP works as intended.

The strangest part is that if we use VLAN 1, untagged, on the HP-switch, the setup does work as intended. How can using a different VLAN, specifically VLAN 1, matter for the connection if its untagged? Is there magic between the two devices I should know about?

HP config:

hostname "SW02-E2"
trunk 45-46 trk10 lacp
stack join e0071b-0000
interface 44
   name "000 WAN"
   exit
snmp-server community "public" unrestricted
vlan 1
   name "DEFAULT_VLAN"
   no untagged 1-24,37-44,49-52,Trk10
   untagged 25-36
   tagged 47-48
   no ip address
   exit
vlan 2
   name "Default vlan2"
   untagged 37-42,49-52,Trk10
   no ip address
   exit
vlan 10
   name "Office network"
   untagged 1-24
   tagged 47-48,Trk10
   ip address 192.168.178.2 255.255.255.0
   exit
vlan 213
   name "VPN network"
   untagged 43-44
   tagged 7-8,10
   ip address 192.168.213.66 255.255.255.192
   exit
vlan 1000
   name "stacking"
   no ip address
   exit
spanning-tree
spanning-tree Trk10 priority 4
spanning-tree mode rapid-pvst
device-profile name "default-ap-profile"
   cos 0
   exit
password manager
password operator
  • The problem is very likely a spanning tree issue as @ronmaupin suggests. If you include the device configurations we can help you sort it out. – Ron Trunk Feb 8 '17 at 18:12
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 16 '17 at 21:48
1

VLAN 1 is the default native (untagged) VLAN. You need to have the native VLAN match between the two switches.

You could also run into STP problems. The Cisco device is going to use PVST+ by default, but the HP can't do that. You may need to change the Cisco device to MSTP.

| improve this answer | |
  • But the point in our setup is that the two devices should be agnostic to each other, why would they need to communicate for, or have, VLANs (1) in sync? – hbogert Feb 8 '17 at 18:39
  • They are switches. Switches run STP and exchange BPDUs. You run into problems with different STP versions. – Ron Maupin Feb 8 '17 at 18:42
  • @hbogert, Cisco has many documents explaining how to inter-operate PVST+ and MST, or how to convert from PVST+ to MST. For example, Understanding Multiple Spanning Tree Protocol (802.1s). – Ron Maupin Feb 8 '17 at 18:48
  • thanks for the document, will read it soon. Should I be able to see the communication of BPDUs between the switches on a port-mirror, or would a port-mirror only show data after this communication? – hbogert Feb 8 '17 at 19:33
  • BPDUs are sent to a special multicast MAC address defined by the IEEE 802.1D standard. Frames sent to this address do not travel beyond the interface on which they are received. Cisco uses a different multicast MAC address for its BPDUs, but the effect is the same. BPDUs are sent on the native VLAN (untagged), and you can run into problems with different native VLANs, Also, the HP switch will have problems with Cisco BPDUs, but the Cisco can use the IEEE BPDUs, but it will have problems with a different VLAN. It is better all the way around to run the same STP version on all the switches. – Ron Maupin Feb 8 '17 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.