1

Why is R1 giving these error messages?

IP-EIGRP(Default-IP-Routing-Table:400): Neighbor 192.168.2.1 not on common subnet for FastEthernet1/0

IP-EIGRP(Default-IP-Routing-Table:400): Neighbor 192.168.2.2 not on common subnet for FastEthernet1/0

enter image description here

R1 is able to ping every router.

Configs:

R1 routing table

     20.0.0.0/29 is subnetted, 1 subnets
D       20.20.20.0 [90/30720] via 192.168.1.2, 00:06:56, FastEthernet1/0
     10.0.0.0/29 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
     192.168.1.0/29 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet1/0
     192.168.2.0/29 is subnetted, 1 subnets
D       192.168.2.0 [90/30720] via 10.10.10.2, 00:06:56, FastEthernet0/0

R1

!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
router eigrp 400
 network 10.10.10.0 0.0.0.7
 network 192.168.1.0 0.0.0.7
 no auto-summary
!
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2

!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 ip address 20.20.20.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.2 255.255.255.248
 duplex auto
 speed auto
!
router eigrp 400
 network 20.20.20.0 0.0.0.7
 network 192.168.1.0 0.0.0.7
 no auto-summary
!
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3

!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.2 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.2.1 255.255.255.248
 duplex auto
 speed auto
!
router eigrp 400
 network 10.10.10.0 0.0.0.7
 network 192.168.2.0 0.0.0.7
 no auto-summary
!
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R4

!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 ip address 20.20.20.2 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.2.2 255.255.255.248
 duplex auto
 speed auto
!
router eigrp 400
 network 20.20.20.0 0.0.0.7
 network 192.168.2.0 0.0.0.7
 no auto-summary
!
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

2 Answers 2

1

EDIT:

EIGRP uses multicast hello packets in order to communicate to other EIGRP neighbors. EIGRP generates the not on common subnet error message when it receives an EIGRP hello packet sourced from an IP address on a subnet that is not configured on its receiving interface.

These are the general cause for this error message:

  • Misconfiguration of the interfaces or switch ports or cabling problem.
  • Mismatch of primary/secondary IP addresses on the neighbor interface.
  • A switch/hub is leaking multicast packets to other ports.
  • If using a LAN switch, the vlans may have joined routers together.
  • Another router uses EIGRP advertising on the same subnet/vlan as this router and is misconfigured with an incorrect AS number.

In order to troubleshoot this issue, check these items:

  • Verify that the cable is connected correctly.
  • Double-check the interface configuration for misconfigured IP addresses on the local and neighboring routers.
  • Verify that the primary address of the interface is in the same subnet as the primary address of the neighbor router.
  • If the EIGRP neighbor connection is joined via a LAN hub, use separate hubs in order to break up the broadcast domain for each logical LAN segment, or configure no eigrp log-neighbor-warnings to eliminate the errors.
  • If there is a switch involved, check the switch configuration to make sure different LAN segments are not configured to be in the same VLAN that share the same broadcast domain.

I would suggest check physical connection and configuration.

3
  • Do you mean anything specific about the IP assignments? 192.168.2.2 is not neighbor. I don´t seem to understand what port fa1/0 has to do with it.
    – Daniel
    Feb 11, 2017 at 18:03
  • EIGRP receives an hello packet sourced from an IP address on a subnet that is not configured on its receiving interface. Check configuration, physical connection etc. Feb 11, 2017 at 18:25
  • I would check switch configuration as for some reasons on F1/0 R1 can see hellos from R3 and R4. If you have single switch for SW1 and SW2 check port configuration. Check if there is any trunks between SW1 and SW2. Feb 11, 2017 at 18:35
1

I was able to fully replicate your topology in GNS3 using IOS 12.4 without any issues or error messages, and without any changes to the configurations you provided.

R2 may have had the incorrect configuration at one point which resulted in error messages on R1. Another possibility is that R1, R3 and R4 were connected to a single SW1 at one time.

The error can also be replicated using your topology by connecting SW1 and SW2 via a single cable.

If you are actively receiving the error messages, I suggest double-checking your EIGRP configurations. You can use the following commands to verify the EIGRP configuration and neighborship.

show ip eigrp neighbors
show running-config | section eigrp
1
  • I was able to resolve the issue with the answer above. I will try those neighbor commands with both the error giving topology and error free one. Thank you for the tips.
    – Daniel
    Feb 17, 2017 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.