1

I think my understanding of Trunking is off. I have two cisco switches under two vlans, connected to a single SRX240. I have connectivity to the SRX from the switch but not anywhere past it. The switch can ping 192.168.8.4 under vlan 89 but cannot ping 192.168.16.2 under vlan 16.

THE SRX CONFIGS

interfaces {
ge-0/0/0 {
    unit 0 {
        description "Eric's Connection";
        family ethernet-switching {
            port-mode access;
            vlan {
                members Group-16;
            }
        }
    }
}
ge-0/0/1 {
    unit 0 {
        description "JSS's Connection";
        family ethernet-switching {
            port-mode access;
            vlan {
                members JSS-89;
            }
        }
    }
}
ge-0/0/2 {
    unit 0 {
        family ethernet-switching {
            vlan {
                members vlan-trust;
            }
        }
    }
}
ge-0/0/3 {
    unit 0 {
        family ethernet-switching {
            vlan {
                members vlan-trust;
            }
        }
    }
}
ge-0/0/4 {
    unit 0 {
        family ethernet-switching {
            vlan {
                members vlan-trust;
            }
        }
    }
}
vlan {
    unit 0 {
        family inet {
            address 192.168.1.1/24;
        }
    }
    unit 16 {
        family inet {
            address 192.168.16.2/24;
        }
    }
    unit 89 {
        family inet {
            address 192.168.8.4/24;
        }
    }
}

}

THE SWITCH CONFIGS

 interface FastEthernet1/0/1
 switchport access vlan 89
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet1/0/2
 switchport access vlan 89
 switchport mode access
!
interface FastEthernet1/0/3
!
interface FastEthernet1/0/4
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
!
interface FastEthernet1/0/7
 switchport access vlan 89
 switchport mode access
!
interface FastEthernet1/0/8
 switchport access vlan 89
 switchport mode access
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
 switchport access vlan 89
 switchport mode access
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
 switchport access vlan 89
 switchport mode access
!
interface FastEthernet1/0/13
!
interface FastEthernet1/0/14
!
interface FastEthernet1/0/15
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan89
 ip address 192.168.8.3 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!

FE1/0/10 is the connection to the SRX.

Any guidance would be great.

Thanks.

9
  • I think you need to explain this a little better. On the switch configuration, you only have one VLAN. Interface FastEthernet1/0/1 is configured as a trunk, but you don't say to what is it connected. You are not trunking to the SRX. Since these are two separate VLANs, you need to use a router (or the layer-3 routing part of a layer-3 switch) to get traffic from one VLAN to another. That means the switch will need a default gateway in its VLAN globally defined in its configuration: ip default-gateway <gateway address>
    – Ron Maupin
    Feb 18, 2017 at 22:54
  • F1/0/1 is connect to a WLC. Sorry, I actually messed with the configs just before posting this. This is what it looks like now. interface FastEthernet1/0/10 switchport trunk encapsulation dot1q switchport mode trunk end But with this, I cannot reach 192.168.8.4 on the router. The VLAN 16 is on another cisco switch with the same sort of configurations set. Thanks.
    – Sou Thong
    Feb 18, 2017 at 22:58
  • The switch has no idea how to reach a different network without a default gateway. Any traffic destined for another network needs to go through the default gateway, which you have not defined.
    – Ron Maupin
    Feb 18, 2017 at 23:03
  • Makes sense. I've added a default route to 192.168.8.4. However with whats configured now, i still cant reach 192.168.8.4. thanks again
    – Sou Thong
    Feb 18, 2017 at 23:08
  • Is the SRX configured for access interfaces and to allow ICMP? You cannot trunk on one side and access on the other side of a link.
    – Ron Maupin
    Feb 18, 2017 at 23:11

1 Answer 1

1

Both the switches will need a default gateway to reach IP addresses on other subnets. Configure the 192.168.8.4 as the default gateway IP on 1 switch

ip default gateway 192.168.8.4

and 192.168.16.2 as the default gateway on the other.

2
  • You cannot put in a default route on a layer-2 switch. The ip default-gateway <gateway address> command is for layer-2 switches. The ip route command would only be used on layer-3 switches that have ip routing enabled.
    – Ron Maupin
    Feb 18, 2017 at 23:06
  • Yes corrected now. Thanks for pointing it out, Ron.
    – Mukesh MV
    Feb 18, 2017 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.