1

I have multiple routers connected to frame relay switches. I am using serial links from the routers to connect to the relay switches. I'm also using an unnumbered loopback address on all of the serial links. When I look at the routing table, the costs of all the routes to other loopbacks are 2. Having some trouble finding out why.

R1 -> FRS1 -> FRS2 -> R2

interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface Tunnel23
no ip address
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex full
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 102 ppp Virtual-Template1
frame-relay interface-dlci 103 ppp Virtual-Template1
frame-relay interface-dlci 104 ppp Virtual-Template1
frame-relay interface-dlci 108 ppp Virtual-Template1
frame-relay interface-dlci 109 ppp Virtual-Template1
!
interface Virtual-Template1
ip unnumbered Loopback0
ip ospf 1 area 0
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0






Gateway of last resort is not set

  1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
  2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.1 [110/2] via 2.2.2.1, 02:28:41, Virtual-Access1




        OSPF Router with ID (1.1.1.1) (Process ID 1)

            Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1038        0x8000001F 0x00BBF0 7
2.2.2.1         2.2.2.1         1294        0x8000001E 0x008625 7

There are more than the two routers but i left them out for clarity. IM using cisco 7200 in GNS3.

Thanks again

7
  • What are the router models and configurations, routing tables, and OSPF database? Also, where doe the virtual links come in? You haven't mentioned how those are connecting through an area.
    – Ron Maupin
    Mar 2 '17 at 15:44
  • This is all being done in GNS
    – Sou Thong
    Mar 2 '17 at 16:06
  • this is all in GNS interface Loopback0 ip address 1.1.1.1 255.255.255.255 ip ospf 1 area 0 ! interface Serial1/0 no ip address encapsulation frame-relay serial restart-delay 0 frame-relay interface-dlci 102 ppp Virtual-Template1 ! interface Virtual-Template1 ip unnumbered Loopback0 ip ospf 1 area 0 no peer neighbor-route ! router ospf 1 network 1.1.1.1 0.0.0.0 area 0 network 192.168.1.0 0.0.0.255 area 0
    – Sou Thong
    Mar 2 '17 at 16:11
  • Routing table 1.0.0.0/32 is subnetted, 1 subnets C 1.1.1.1 is directly connected, Loopback0 2.0.0.0/32 is subnetted, 1 subnets O 2.2.2.1 [110/2] via 2.2.2.1, 02:28:41, Virtual-Access1 OSPF database Router Link States (Area 0) Link ID ADV Router Age Seq# Checksum Link count 1.1.1.1 1.1.1.1 1038 0x8000001F 0x00BBF0 7 2.2.2.1 2.2.2.1 1294 0x8000001E 0x008625 7 Thanks again Ron.
    – Sou Thong
    Mar 2 '17 at 16:12
  • Edit your question to include what I have asked for, and use the Preformatted Text feature. It is unreadable in a comment.
    – Ron Maupin
    Mar 2 '17 at 16:12
0

You haven't really given enough details about how you you have virtual links connected, but virtual links end up with the costs of the individual hops added together, just as if there wasn't a virtual link.

For example, consider this scenario:

  Area 0         |                 Area 1               |    Area 2
  Cost 10               Cost 10              Cost 10             Cost 10 
10.0.0.0/24<-->R1<--> 10.0.1.0/24<-->R2<-->10.0.2.0/24<->R3<-->10.0.3.0/24

R3 has a virtual link to R1 in Area 0 The cost that R3 sees across the virtual link to 10.0.0.0/24 in Area 0 is 30.

Cisco has a document that explains OSPF virtual links: OSPF Virtual Link

5
  • OK i guess im way further off than i had thought. I assumed the virtual template i assigned to s1/0 was creating that virtual link. In the routing table the link to 2.2.2.1 had a cost of 2 with a egress interface of Virtual-Access1.
    – Sou Thong
    Mar 2 '17 at 16:40
  • You don't have a virtual link in your configuration.
    – Ron Maupin
    Mar 2 '17 at 16:41
  • I was trying to configure ospf point-to-point using unnumbered loopbacks over frame relay. I suppose the virtual template worked for me in this case.
    – Sou Thong
    Mar 2 '17 at 16:45
  • I am confused. Where do you think you have a virtual link? A virtual template has nothing to do with OSPF virtual links. If you are trying to test virtual links, you are going about it completely incorrectly.
    – Ron Maupin
    Mar 2 '17 at 16:52
  • Yes, I was confused about what it was I was using. The end goal was to use OSPF in point-to-point mose using unnumbered loopback. The site you referenced earlier cleared that up.
    – Sou Thong
    Mar 2 '17 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.