2
Here is the configuration:

Current configuration : 154 bytes
!
interface Port-channel1
 description TRUNK
 switchport trunk allowed vlan 10,20
 switchport mode trunk
end


interface GigabitEthernet1/0/47
 description SW1
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 speed 1000
 duplex full
 channel-protocol lacp
 channel-group 1 mode active
end


interface GigabitEthernet1/0/48
 description SW1
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 speed 1000
 duplex full
 channel-protocol lacp
 channel-group 1 mode active
end

I have verified and other side of switch has same configuration. i have matched them word to word.

Here is the etherchannel summary

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi1/0/47(P) Gi1/0/48(s)

On switch port i have seen Amber light

In log i have seen:

Feb 28 22:39:45.558: %EC-5-L3DONTBNDL2: Gi1/0/48 suspended: LACP currently not enabled on the remote port.

etherchannel details:

#sh etherchannel 1 detail
Group state = L2
Ports: 2   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
Minimum Links: 0


        Ports in the group:
        -------------------
Port: Gi1/0/47
------------

Port state    = Up Mstr Assoc In-Bndl
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi1/0/47  SA      bndl      32768         0x1       0x1     0x130       0x3D

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi1/0/47  SA      32768     6c99.8962.2900   0s    0x0    0x10   0x110   0x3D

Age of the port in the current state: 1d:17h:22m:19s

Port: Gi1/0/48
------------

Port state    = Up Cnt-bndl-rmt Suspend Mstr Rmt-LACP_Dsbl Not-in-Bndl
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = null        GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi1/0/48  SA      susp      32768         0x1       0x1     0x131       0x7D

Age of the port in the current state: 0d:00h:28m:16s

        Port-channels in the group:
        ---------------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 1d:17h:26m:42s
Logical slot/port   = 9/1          Number of ports = 1
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi1/0/47 Active             0

Time since last port bundled:    1d:17h:22m:19s    Gi1/0/47 

Otherside switch SW1 i am seeing this.

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
16     Po16(SU)        LACP      Gi1/0/14(D) Gi1/0/15(P)

interface status:

SW1#sh int Gi1/0/14
GigabitEthernet1/0/14 is down, line protocol is down (notconnect)
8
  • If you are connecting two Cisco switches, you should really eliminate the layer-2 protocol and just use channel-group 1 mode on to channel unconditionally. LACP is useful for setting up a channel to a server that needs LACP, but it adds complexity and overhead that you don't need to have on a switch-to-switch connection if both are Cisco switches. – Ron Maupin Mar 2 '17 at 16:23
  • They are cisco switch but this is not first time we did, we have 25 cisco switch and i have same configuration on all of switch.. i have never seen issue like this before. – Satish Mar 2 '17 at 16:44
  • You may have a bad cable, or you are connected the wrong interface on the other end. According to G1/0/48, the interface on the other end G1/0/14 is not running LACP. Is it correct that G1/0/48 on one switch is supposed to connect to G1/0/14 on the other switch? – Ron Maupin Mar 2 '17 at 16:50
  • 1
    What does show cdp neighbor say? The G1/0/48 interface on one switch is obviously connecting to the G1/0/14 on the other switch. Is that correct? – Ron Maupin Mar 2 '17 at 17:05
  • 1
    I have had so many problems with the on-site guys swearing everything is connected correctly, and tell me that they have traced the cables multiple times, but then I prove them wrong with CDP. – Ron Maupin Mar 2 '17 at 17:14
1

This often happens when you connect to an interface that doesn't have LACP enabled, as you have discovered. Using CDP or LLDP will tell you for sure what the interface on the other end is, assuming you have one of those enabled on both devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.