My server should receive routes via RIP.
I have tried it with Bird on Ubuntu 10.04.
The server should work with the interface option passive.
(Receive routes and not send)

protocol kernel {
    scan time 20;
    export all;            

protocol device {
    scan time 10;           

protocol rip {
    export none;
    import all;
    interface "eth0" {
            passive yes;
    debug all;

If I start bird, I get

bird: /etc/bird.conf, line 15: syntax error
  • Try deleting "yes" after passive.
    – ar_
    Mar 8 '17 at 15:13
  • The same result. I tried "yes", "true" and "".
    – Trilex
    Mar 8 '17 at 15:15
  • Just tried this in lab. Doesn't work with version and passive statement. No ideas so far.
    – ar_
    Mar 8 '17 at 15:41

I had the bird version from the official repositorie (bird 1.1.5-1).
This version is very old and the option passive don't work.
I update bird to 1.6.3 and everything works.
Thanks to the BIRD Mailing List! (http://bird.network.cz/pipermail/bird-users/2017-March/011074.html)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.