2

current configuration is that in my office we are using netgear GS switches which are configured as VLAN1 and VLAN2. VLAN2 is for Voice. We have a Avaya Ip Phone System on a 192.168.200.XX. The Data Network is 192.168.100.xx The Switch ports are configured with both Data & Voice so when we connect a avaya phone to one of the ports it will detect it and give an IP from AVAYA Communication Manage which is on 192.168.200.xx also we can connect a laptop to the phone and it will get a IP address from 192.168.100.xx

Problem I recently bought a Cisco 3750G-24P Switch, and trying to do the same but the avaya phone does not pick up IP address from the 200.xx but when I connect the PC to the same port it picks up a IP from the DHCP.

Question How can i correctly configure my cisco router so that I can achieve what netgear switch does.

Unfortunately I am a noobe so step by step instructions is appreciated so i can lean as well

Thank you so much

************* current Config****** edited on 150317******

vlan 2
 name avayaip-phone  
!  
vlan 101,401  
lldp run  
!  
!  
!  
interface GigabitEthernet1/0/1  
!  
interface GigabitEthernet1/0/2  
 switchport access vlan 2  
 switchport mode access  
!  
interface GigabitEthernet1/0/3  
 switchport access vlan 2  
 switchport mode access  
 switchport voice vlan 2  
 ip dhcp relay information check-reply  
 spanning-tree portfast  

  • Cisco defaults to using CDP, with LLDP disabled. You are going to need to enable LLDP. – Ron Maupin Mar 13 '17 at 21:02
  • 1
    Please post 3750 configuration so we see what is missed in your config – Mr.lock Mar 14 '17 at 17:29
  • @RonMaupin, Thank you for your comment. As I am new to Cisco Switch Programming, could you provide me with a sample config. so I can try it out in my system – Rochelle N Nilanga Chandraseke Mar 15 '17 at 7:44
  • @Mr.lock, Thank you for your comment. Right now i reset the switch to factory defaults. So there are no configuration. I was hoping to Re-Program the switch from the scratch. – Rochelle N Nilanga Chandraseke Mar 15 '17 at 7:45
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 17 '17 at 3:59
1

First, enable lldp globally:

lldp run

Then also configre lldp on each interface. The native vlan should be vlan 1 (data) and the voice vlan should be 2, like this:

interface GigabitEthernet1/0/3  
 switchport access vlan 1  
 switchport mode access  
 switchport voice vlan 2  
 ip dhcp relay information check-reply  
 spanning-tree portfast
 lldp transmit
 lldp receive 
  • Thank you for your comment. I tried what u have given too. But yet its not picking up IP from My dhcp. Don't know what I am doi ng wrong. :( – Rochelle N Nilanga Chandraseke Mar 16 '17 at 8:51
  • This is how my config looks like; lldp run ! ! ! interface GigabitEthernet1/0/1 ! interface GigabitEthernet1/0/2 switchport access vlan 2 switchport mode access ! interface GigabitEthernet1/0/3 switchport trunk encapsulation dot1q switchport mode access switchport voice vlan 2 ip dhcp relay information check-reply spanning-tree portfast ! interface GigabitEthernet1/0/4 switchport mode access switchport voice vlan 2 ip dhcp relay information check-reply spanning-tree portfast ! – Rochelle N Nilanga Chandraseke Mar 16 '17 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.