2

We have a Juniper EX4200. Ports 0, 2, 4 and 6 are connected to another Juniper switch. These ports are our network uplinks. All other ports are connected to our servers. We want traffic to use all 4 uplinks (total capacity 4 Gbps), but it seems like only the first port (0) is every used, all other show no or little traffic, even under heavy load.

Our switch :

# show interfaces
ge-0/0/0 {
    unit 0 {
        family ethernet-switching;
    }
}

...

# show interfaces vlan
unit 401 {
    family inet {
        address e.f.g.2/29;
    }
}
unit 101 {
    family inet {
        address a.b.c.1/29;
    }
}
unit 102 {
    family inet {
        address a.b.c.9/29;
    }
} 
...

#show vlans
server-1 {
    vlan-id 101;
    interface {
        ge-0/0/1.0;
    }
    l3-interface vlan.101;
}
server-2 {
    vlan-id 103;
    interface {
        ge-0/0/3.0;
    }
    l3-interface vlan.103;
}
default {
    vlan-id 401;
    l3-interface vlan.401;
}
v401;

...

show routing-options
static {
    route 0.0.0.0/0 next-hop e.f.g.1;
}

Our switch ports 0, 2, 4 and 6 connects to ports 0, 1, 2 and 3 of the upstream switch. The upstream switch is configured like :

set routing-options static route a.b.c.1/24 next-hop e.f.g.2

set interfaces ge-0/0/0 unit 0 family ethernet-switching
set interfaces ge-0/0/1 unit 0 family ethernet-switching
set interfaces ge-0/0/2 unit 0 family ethernet-switching
set interfaces ge-0/0/3 unit 0 family ethernet-switching

set vlans v401 vlan-id 401
set vlans v401 interface ge-0/0/3.0
set vlans v401 interface ge-0/0/2.0
set vlans v401 interface ge-0/0/1.0
set vlans v401 interface ge-0/0/0.0
set vlans v401 l3-interface vlan.401

Why aren't we seeing traffic flowing through the 3 other uplinks?

  • 3
    Spanning tree will select exactly one path toward the root switch, and it will block the other paths. This prevents layer-2 loops that will lead to broadcast storms that will bring down your LAN. You could look at LAG, which is a method to fool STP into thinking that the multiple links are a single link, but it must be configured on both switches. – Ron Maupin Mar 16 '17 at 12:45
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 12 '17 at 5:13
3

As Ron has mentioned, this is most likely the result of spanning-tree blocking the remaining three interfaces, as you have created a loop in your network.

To achieve what you're after (load-sharing/flow-hasing), configure the following on BOTH switches to form an aggregated ethernet link:

set chassis aggregated-devices ethernet device-count 8

wildcard range delete interfaces ge-0/0/[0-3]
wildcard range delete vlans v401 interface ge-0/0/[0-3]

set interfaces interface-range AE0-MEMBERS ether-options 802.3ad ae0
wildcard range set interfaces interface-range AE0-MEMBERS member ge-0/0/[0-3]
set interfaces ae0 aggregated-ether-options lacp active

set interfaces ae0 unit 0 family ethernet-switching
set vlans v401 interface ae0 

I'm not a fan of assigning interfaces to the VLAN, so you can replace the last line with:

set interfaces ae0 unit 0 family ethernet-switching members v401

I liken Junos VLAN assignment to the eternal struggle over which side of the roll toilet paper should be hung.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.