4

I am new to the networking world and am attempting my first few projects in Packet Tracer. The first few were easy but I've gotten to a road block.

My goal is to have three separate VLANs with at least one client on each VLAN. My goal is to use a layer 3 switch for inter-VLAN routing so that I am able to setup the L3 switch as a VTP server, two other switches as VTP clients, and have each client switch connect to various VLANs.

The problem is: I cannot figure out how to get pings to work between the VLANs coming from different switches. I've attached my network topography and the configurations for each switch. Please help!!

Any help would be GREATLY appreciated.

Switch 1 (VTP Client 1) 

Current configuration : 1566 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname anton

!

!

!

!

!

spanning-tree mode pvst

!

interface FastEthernet0/1

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 10

!

interface FastEthernet0/3

switchport access vlan 10

!

interface FastEthernet0/4

switchport access vlan 10

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

mac-address 00e0.8f04.7201

ip address 192.168.10.254 255.255.255.0

!

interface Vlan20

mac-address 00e0.8f04.7202

ip address 192.168.20.254 255.255.255.0

!

interface Vlan30

mac-address 00e0.8f04.7203

ip address 192.168.30.254 255.255.255.0

!

interface Vlan99

mac-address 00e0.8f04.7204

ip address 192.168.99.10 255.255.255.0

!

ip default-gateway 192.168.10.0

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

!

end

Switch 2 (VTP Client 2)

Current configuration : 1582 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname anton

!

!

!

!

!

spanning-tree mode pvst

!

interface FastEthernet0/1

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 20

!

interface FastEthernet0/3

switchport access vlan 30

!

interface FastEthernet0/4

switchport access vlan 30

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

mac-address 00e0.a334.8b03

ip address 192.168.10.254 255.255.255.0

!

interface Vlan20

mac-address 00e0.a334.8b01

ip address 192.168.20.254 255.255.255.0

!

interface Vlan30

mac-address 00e0.a334.8b02

ip address 192.168.30.254 255.255.255.0

!

interface Vlan99

mac-address 00e0.a334.8b04

ip address 192.168.99.10 255.255.255.0

!

ip default-gateway 192.168.10.0

!

!

!

!

line con 0

!

line vty 0 4

password cisco

login

line vty 5 15

login

!

!

!

end

Layer 3 Switch (VTP Server)

Current configuration : 1708 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname anton
!
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 00d0.5894.8e01
ip address 192.168.10.254 255.255.255.0
!
interface Vlan20
mac-address 00d0.5894.8e02
ip address 192.168.20.254 255.255.255.0
!
interface Vlan30
mac-address 00d0.5894.8e03
ip address 192.168.30.254 255.255.255.0
!
interface Vlan99
mac-address 00d0.5894.8e04
ip address 192.168.99.10 255.255.255.0
!
ip default-gateway 192.168.10.0
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

The Network Topography

3

It seems you have the SVI for VLANs 10, 20, and 30 configured on all three switches. This is going to cause an IP conflict.

The only switch that actually needs the SVI is whatever switch that will be doing the routing. All the others just need to simply forward data at L2. From what I can gather, that would be your Switch 3.

I would suggest reading through this article to help understand the different options for routing between VLANs, and specifically this section on using a Layer 3 Switch.

| improve this answer | |
  • 1
    I just wanted to come back and tell you that those resources were great in helping increase my understanding of what's going on here.. I just finished an even more complex version of what I posted and everything is working like a charm! Thanks again @Eddie – Anton Rasmussen Mar 17 '17 at 0:59
  • 1
    @AntonRasmussen Glad you enjoyed them, Anton. There are a few other series on that site which are really good for folks new to the field, specifically the Packet Traveling series. – Eddie Mar 17 '17 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.