on my network vlan1 is to be non routed management traffic between switches etc. vlan2 is general network vlan3 is wifi vlan4 is a point to point between routed interfaces vlan5 for servers.

Currently I have a trunk on port 3 of the isr so it can pass vlan1 & 3. I had just recently realized the reason my routed traffic was not going any where on the 6500 was due to my not using a layer3 interface (I think).

I have tried setting up port 2 on the isr as an access port with vlan4 as the native. I tried setting the layer3 on the 6500 as vlan4 and no response. I then tried sub-interfaces to get it to respond with no luck. it wont let me set vlan1 on sub-interfaces either so I suspect that wont work well either.

the isr has no issues routing to the internet. If I add a vlan2 address and set the isr as the gateway there are no issues getting out.

  • You need to edit your question to include the router and switch configurations.
    – Ron Maupin
    Mar 17, 2017 at 17:22
  • 1
    The port on the 6500 needs to be in the same subnet as vlan 4. Then you need to run a routing protocol between them.
    – Ron Trunk
    Mar 17, 2017 at 22:25

2 Answers 2


It appears that the config didn't apply properly the first time or I some how got things confused between the two devices.

on the layer2 port of the isr access mode and vlan setting need to be applied. on the Layer3 device the ip needs to be applied as well as the vlan setting.

if its a layer2 trunk then on the layer 3 side a sub interface would be needed.

As Ron mentioned ospf or another routing protocol has to be turned on on the 6500 series to allow routing to happen properly. the ISR is able to route with ip route command


Packet exchange between IP endpoints on differing subnets occurs through a gateway/router. VLANs need to be created on both devices and a trunk link enabled between the two. Layer 3 interfaces created and maybe routing/static routes? Endpoints typically get IP addresses and default gateway addresses via DHCP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.