1

I have a doubt. IP addresses of the PCs connected to this network do not seem to change every time they connect to the network. I should tidy up the IP addresses, respecting the physical layout of the PC. The firewall is a fortigate 90d, while the firmware version is v5.0

I post a picture, to understand how the network is set: enter image description here

--UPDATE-- I tried to reserve an IP address, but the PC network card fails to obtain the ip: enter image description here

2

@Nroot: your explanation is not quite right. The FGT doesn't reserve an address for a specific MAC address unless manually configured to do so. Rather, the client requests the same address as previously obtained. And shortening the lease interval will just create more traffic, not more addresses - for the same reason.

If you want to control the address a host uses either assign static addresses or set up reserved DHCP addresses on the FGT.

| improve this answer | |
  • I tried to reserve an IP address, but the PC network card fails to obtain the ip: i.stack.imgur.com/KZy8H.jpg – nicovon Mar 27 '17 at 7:16
  • Should work if PC and fw are in the same network. Try the option "add from client list", ie. let the PC get a dynamic IP and then fix the assignment in the FGT. – user1016274 Mar 27 '17 at 7:22
  • it worked! you are a great! – nicovon Mar 27 '17 at 7:28
0

Please explain what do you mean by saying "tidy up", and "respecting the physical layout of the PC"? And it's not a bad thing to have your pc get same ip add eventhou it's getting it from dynamic dhcp pool. It's just mean that in dhcp binding table of the fortinet your pc mac address is associated with that offered ip add. You can make dhcp changing more frequently on pc if you decrease dhcp lease time on fortinet dhcp pool configuration. I hope this helps

| improve this answer | |
  • I would start with the first PC and assign the IP 192.168.32.150, then move on second PC and assign 192.168.32.151 and so on .. – nicovon Mar 25 '17 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.