1

As part of my internship/thesis, I am looking to implement HSRP in a network.

The network has 2 separate locations that are connected with a fibre cable (layer 3 to layer 3).

Each layer 3 (Cisco 3560-x) is connected to an HP-router that is managed by our ISP.

I was thinking about setting up HSRP on one interface of both switches, but I imagine an IP route to the virtual IP address won't work because it is on the same switch.

Would I be correct to think that in my current configuration, HSRP is only possible on the routers?

Any other input regarding the issue is welcome.

EDIT

extra info:

Router 1 IP address is 10.10.255.251 and Router 2 IP address is 10.10.255.252.

Switch1 :

interface FastEthernet0/1
 no switchport
 ip address 10.10.255.253 255.255.255.248
 standby 1 ip 10.10.255.250
 standby priority 110
 exit

Switch2:

interface FastEthernet0/1
 no switchport
 ip address 10.10.255.254 255.255.255.248
 standby 1 ip 10.10.255.250
 standby priority 110
 exit

The reason why I want to do this on the switches is that I can't configure the routers as they are managed by our ISP.

The virtual IP address would be 10.10.255.250, but when this is configured on the switch interfaces, I cannot add an IP route to this virtual IP address because the next hop would be on the same switch.

I also don't see how the Internet traffic would reach the routers in this configuration.

So, to repeat the question: am I right in thinking this won't work, or is this possible in a way that I did not try yet?

  • On which interfaces you want to enable the HSRP, keep in your mind that to enable HSRP on two interfaces they should be L2 connected and have IP,s which is belong to the same subnet and the virtual IP should be on the same subnet as well – Mr.lock Apr 1 '17 at 8:17
  • "i imagine an ip route to the virtual IP won't work because it is on the same switch." I don't really understand that. You are going to configure the IP route on which device(s)? HSRP is a protocol to fool network hosts. Each of the two routers running HSRP sets up a layer-3 interface with real IP addresses in a single layer-2 LAN, and they communicate in the LAN to determine which is the primary, and which is the secondary. The hosts in that LAN use the virtual gateway. Where would you set up a static route? – Ron Maupin Apr 1 '17 at 11:27
  • Currently the switches use an IP route to direct internet traffic to the routers. These routers are managed by our ISP so we cannot change the configuration on these routers. So i wanted to see if i can implement HSRP on the switches instead. This would be on the interfaces that currently have a fixed ip. I added extra info in the original post to clarify – Sibeal Apr 1 '17 at 17:25
0

What you seem to be proposing is running HSRP toward the ISP routers in attempt to fool your own routers, but HSRP is a protocol designed to fool LAN hosts, e.g. PCs.

On your layer-3 switches, you will have one or more VLANs configured in SVIs. For example:

ip routing
!
interface Vlan10
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan20
 ip address 10.20.20.1 255.255.255.0

Those are the interfaces on which you would configure HSRP to give a redundant gateway to your LAN hosts.


If you want redundancy to the ISP routers, you need to do that with routing. You probably have a static default route. For example, assume the ISP routers are 10.10.255.249 (primary) and 10.10.255.250 (backup):

ip route 0.0.0.0 0.0.0.0 10.10.255.249     ! primary route with AD of 1
ip route 0.0.0.0 0.0.0.0 10.10.255.250 10  ! backup route with AD of 10

This establishes two static default routes. A lower AD will be in the routing table unless it goes down, at which point it is removed from the routing table, and the backup route is put into the routing table.

This is invisible to the hosts because the hosts use the layer-3 switches for their gateways. Hosts don't know or care about the routing; all they care about is that they have a configured gateway, and the gateway is supposed to know how to route traffic toward the destination.

  • thanks, this is what i was looking for, i didn't know of AD on ip routes, i haven't used AD before in my classes. adding another location will also be easy with this AD on ip routes – Sibeal Apr 1 '17 at 22:54
  • Another question about these ip routes: If I put only these 2 default routes on switch 1, but the router with ip 10.10.255.250 is linked to the second switch, I will not be able to reach it, right? I would need to direct it to the second switch where it can be directed to the router. The same issue arises on the other switch: I need to put a default route to switch 1 with AD1 and default route to router with AD 10. switch 2 won't know if the link from switch 1 to router 1 is down, so this creates a loop. Is this an issue that OSPF solves? – Sibeal Apr 3 '17 at 1:38
  • You need to create a WAN router VLAN on your switches. Since it appears both WAN routers are in the same layer-3 network, you could get in some real trouble unless you simply create a VLAN and place the switch addresses on the SVIs for that VLAN. That way, the WAN routers and the switches are all on the same layer-2 network. – Ron Maupin Apr 3 '17 at 1:48
  • does this vlan include the interfaces that are used to link switch 1 to switch 2? or do i trunk these interfaces and allow that vlan to use the trunk? – Sibeal Apr 3 '17 at 2:06
  • You are going to have a trunk between the two switches, and you include the WAN VLAN on the trunk. The interfaces from the switches to the WAN routers will be access interface in that VLAN. – Ron Maupin Apr 3 '17 at 2:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.