2

My problem is that I declared a static route in a Cisco ASR-901 and it is shown while doing show ip route:

SOYUNCORESWITCH(config)#do sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
   a - application route
   + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 192.168.3.254 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.3.254
                [1/0] via 192.168.3.1
      172.26.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.26.248.96/27 is directly connected, Vlan60
L        172.26.248.114/32 is directly connected, Vlan60
      192.168.3.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.3.0/24 is directly connected, FastEthernet0/0
S        192.168.3.66/32 [1/0] via 192.168.3.64
L        192.168.3.99/32 is directly connected, FastEthernet0/0
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.8/29 is directly connected, Vlan100
L        192.168.10.12/32 is directly connected, Vlan100
SOYUNCORESWITCH(config)#

But, when I try to ping 192.168.3.66 it does not respond:

SOYUNCORESWITCH#ping 192.168.3.66
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.66, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
SOYUNCORESWITCH#

I checked the route on the other end and it is ok, so is there anything missing? or badly done?

PD: Here is the current configuration of the router:

SOYUNCORESWITCH#sh run Building configuration...

Current configuration : 3534 bytes
!
! Last configuration change at 21:05:11 UTC Sun Apr 17 2011 by r03py
! NVRAM config last updated at 20:20:41 UTC Sun Apr 17 2011 by r03py
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname SOYUNCORESWITCH
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$f743$eVtDaxgWmCvSPcOoi4qKB0
!
no aaa new-model
ethernet lmi global
ip cef
!
no ipv6 cef
!
multilink bundle-name authenticated
l3-over-l2 flush buffers
asr901-storm-control-bpdu 1000
!
spanning-tree mode pvst
spanning-tree extend system-id
license udi pid A901-6CZ-FS-A sn CAT2043U1RN
license boot level AdvancedMetroIPAccess
<removed>    !
cdp run
!
interface Loopback0
 no ip address
!
interface GigabitEthernet0/0
 description ver_asr_901_pg_358
 mtu 1500
 no ip address
 negotiation auto
 cdp enable
 service instance 60 ethernet
  description ##### CONEXION A RED MPLS  #####
  encapsulation dot1q 60
  rewrite ingress tag pop 1 symmetric
  bridge-domain 60
 !
!
interface GigabitEthernet0/1
 description #####  CONEXION CON WAN TECO  #####
 mtu 1500
 no ip address
 negotiation auto
 service instance 100 ethernet
  encapsulation untagged
  bridge-domain 100
 !
!
interface GigabitEthernet0/2
 no ip address
 negotiation auto
!
interface GigabitEthernet0/3
 mtu 1500
 no ip address
 negotiation auto
 cdp enable
!
interface GigabitEthernet0/4
 no ip address
 media-type auto-select
 negotiation auto
!
interface GigabitEthernet0/5
 no ip address
 media-type auto-select
 negotiation auto
!
interface GigabitEthernet0/6
 no ip address
 media-type auto-select
 negotiation auto
!
interface GigabitEthernet0/7
 no ip address
 media-type auto-select
 negotiation auto
!
interface GigabitEthernet0/8
 no ip address
 negotiation auto
 qos-config scheduling-mode min-bw-guarantee
!
interface GigabitEthernet0/9
 no ip address
 negotiation auto
 qos-config scheduling-mode min-bw-guarantee
!
interface GigabitEthernet0/10
 no ip address
 negotiation auto
 qos-config scheduling-mode min-bw-guarantee
!
interface GigabitEthernet0/11
 no ip address
 negotiation auto
 qos-config scheduling-mode min-bw-guarantee
!
interface TenGigabitEthernet0/0
 no ip address
 qos-config scheduling-mode min-bw-guarantee
!
interface TenGigabitEthernet0/1
 no ip address
 qos-config scheduling-mode min-bw-guarantee
!
interface FastEthernet0/0
 ip address 192.168.3.99 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan60
 ip address 172.26.248.114 255.255.255.224
!
interface Vlan100
 ip address 192.168.10.12 255.255.255.248
!
interface Vlan777
 ip address 172.17.17.66 255.255.255.252
!
router ospf 100
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route static adjust-time 3
ip route 0.0.0.0 0.0.0.0 192.168.3.254
ip route 0.0.0.0 0.0.0.0 192.168.3.1
ip route 172.17.17.64 255.255.255.252 GigabitEthernet0/3
ip route 172.17.17.64 255.255.255.252 72.17.17.66 permanent
ip route 192.168.3.66 255.255.255.255 192.168.3.64
ip route 192.198.3.64 255.255.255.252 GigabitEthernet0/3
ip ospf name-lookup
!
no service-routing capabilities-manager
!
control-plane
!
environment monitor
!
line con 0
line vty 0 4
 exec-timeout 15 0
<removed>
 private
 logging synchronous
 login local
 transport input telnet
line vty 5 15
 login local
 transport input telnet
!
exception crashinfo buffersize 128
!
end
  • I removed your passwords from the config. – Ron Trunk Apr 17 '17 at 17:32
  • 1
    There are a number of reasons why ping doesn't work, and they may have nothing to do with the router. In fact your static route is unnecessary--the address is locally connected. That leads me to believe the problem is elsewhere. – Ron Trunk Apr 17 '17 at 17:35
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 17 '17 at 5:30
1

You have a problem with this command:

ip route 192.198.3.64 255.255.255.252 GigabitEthernet0/3

That interface has no IP configuration:

interface GigabitEthernet0/3
 mtu 1500
 no ip address
 negotiation auto
 cdp enable
!

The FastEthernet0/0 interface already has the IP addressing for the 192.198.3.0/24 network that encompasses the 192.198.3.64/30 network you are trying to use on the GigabitEthernet0/3 interface.

That will not work. You cannot have the same or overlapping networks on two different layer-3 interfaces. If you want GigabitEthernet0/3 to be a switch interface, then you need to set it up that way with a VLAN, and define an SVI for that VLAN (it defaults to VLAN 1 that you have shut down), but you cannot assign addressing to the SVI that overlaps the network on FastEthernet0/0.

It looks like you are trying to confuse layer-2 and layer-3.

0

I spotted one typos on the configuration.
ip route 172.17.17.64 255.255.255.252 72.17.17.66 permanent

is this correct IP ? 172.17.17.66

permanent is not recommended value. It cannot detect gateway is down.

ip route 0.0.0.0 0.0.0.0 192.168.3.254
ip route 0.0.0.0 0.0.0.0 192.168.3.1
Multiple ip route destination is is configured. Is not the value of administrative distance necessary?

  • Actually, the static routes will have an AD of 1, but the directly connected network will have an AD of 0, so the static routes are gratuitous, and they will never be used. – Ron Maupin Apr 19 '17 at 0:44
  • @RonMaupin That's the Best advice.Another problem is that the Mac table is not displayed. Put your show ip arp result. And your EVC result. show ethernet service instance show bridge-domain result – Roger Sanghee Gold Apr 19 '17 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.