1

I have created the following Network in GNS3 GNS3 Simple Network Diagram Let me explain the SetUp:

  1. The internet cloud Cloud 1 is connected to my LAN and not loopback.
  2. R1 routers' F0/0 is getting the IP from DHCP, to which i can telnet and ping from any remote host in my LAN.
  3. R1 also configured with SNMP access (public community string)
  4. The IP for R1 routers' F0/1 interface is manually configured.
  5. This interface i can ping from any remote host on my LAN however Telnet fails. R2 routers' F0/0 ip is manully configured. The situation is same here, where i am able to ping however telnet is failing. All the configuration is same between R1 and R2.

Just mentioning again, all the interfaces are ping-able from any Remote Host in the same LAN, however only R1's F0/0 is telnet-able (hope that is a word)

Is there some configuration change that i can do to get telnet access to all the interfaces?

P.S: My cloud internet gateway is 10.226.22.1

Configuration of R1:

Building configuration...

Current configuration : 2016 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 duplex half
!
interface FastEthernet1/0
 ip address 10.226.22.34 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
!
interface Ethernet4/0
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/1
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/2
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/3
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/4
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/5
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/6
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/7
 no ip address
 shutdown
 duplex half
!
interface FastEthernet5/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet5/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial6/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 network 10.0.0.0
!
ip route 0.0.0.0 0.0.0.0 10.226.22.1
!
ip http server
no ip http secure-server
ip http path flash:
!
!
snmp-server community public RO
no cdp advertise-v2
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-conferences 4 gain -6
 web admin system name cisco secret 5 $1$1pTn$/eGx7afnUPhFB2AqoFApH.
 dn-webedit
 time-webedit
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end

Configuration of R2:

Building configuration...

Current configuration : 2119 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.226.22.35 255.255.255.224
 duplex half
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
!
interface Ethernet4/0
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/1
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/2
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/3
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/4
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/5
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/6
 no ip address
 shutdown
 duplex half
!
interface Ethernet4/7
 no ip address
 shutdown
 duplex half
!
interface FastEthernet5/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet5/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial6/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial6/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 network 10.0.0.0
!
ip route 0.0.0.0 0.0.0.0 10.226.22.34
!
ip http server
no ip http secure-server
ip http path flash:
!
!
no cdp advertise-v2
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-conferences 4 gain -6
 web admin system name cisco secret 5 $1$/jP3$0HbV8qC5BIn8Ezww4Nuv7.
 dn-webedit
 time-webedit
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
 login
 transport input telnet
 transport output telnet
line vty 5 15
 login
 transport input telnet
 transport output telnet
!
!
end

As an additional info, my gateway for R1 is 10.226.22.1 which is not reachable from R2. (Maybe i need to somehow get the gateway reachable from R2?)

Routing info of R1:

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.226.22.1 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
S       10.238.60.13/32 [254/0] via 10.226.22.1, FastEthernet0/0
C       10.226.22.32/27 is directly connected, FastEthernet1/0
C       10.226.22.0/27 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.226.22.1

Routing info of R2:

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.226.22.34 to network 0.0.0.0

     10.0.0.0/27 is subnetted, 2 subnets
C       10.226.22.32 is directly connected, FastEthernet0/0
R       10.226.22.0 [120/1] via 10.226.22.34, 00:00:15, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.226.22.34
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Feb 19 '18 at 3:38
1

When you want to telnet to a Cisco device, you must have a password configured for the VTY lines. Use something like this:

line vty 0 15
 logging synchronous
 exec-timeout 15 0
 password <your telnet password>
 login
 transport input telnet
!
0

on Cisco router try this command

line vty 0 15
transport input telnet
transport output telnet

These above commands will help you to activate telnet the reason would be when you try to telnet R1 from lan the input command would be given but when it passes through R1 to R2 it won't able to telnet as output command is not given try this

  • i tried doing this, but the output was still the same "connection refused" – Wilbur Dsouza Apr 18 '17 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.