2

I have a layer 3 switch with multiple VLANs.

I created a trunk port that connects to a layer 2 switch.

I can now successfully access the layer 3 switch VLANs from an access port on the layer 2 switch.

However, I am not sure how to make the switches themselves talk to each other directly, i.e. so I can telnet from one switch to another.

Should I make a "network management" VLAN and assign an IP on each switch? I tried this, however each switch can't even ping itself on this address. Perhaps this is because I didn't assign the VLAN to any access port, however it would seem like a waste of a port, as I only want them to talk through the trunk port.

What is the standard way to go about this?


Full Layer 3 Switch:

Current configuration : 5362 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname pac-inet-cs1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-24t
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
ip name-server 8.8.8.8
ip name-server 4.4.4.4
ip dhcp excluded-address 192.168.30.1 192.168.30.10
ip dhcp excluded-address 192.168.32.1 192.168.32.10
ip dhcp excluded-address 192.168.36.1 192.168.36.10
!
ip dhcp pool Vlan30
   network 192.168.30.0 255.255.255.0
   domain-name mailpac.net
   default-router 192.168.30.1
   dns-server 8.8.8.8
!
ip dhcp pool Vlan32
   network 192.168.32.0 255.255.255.0
   domain-name mailpac.net
   default-router 192.168.32.1
   dns-server 8.8.8.8
!
ip dhcp pool Vlan36
   network 192.168.36.0 255.255.255.0
   domain-name mailpac.net
   default-router 192.168.36.1
   dns-server 8.8.8.8
!
!

!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
 switchport access vlan 71
 switchport mode access
!
interface GigabitEthernet1/0/2
 switchport access vlan 71
 switchport mode access
!
interface GigabitEthernet1/0/3
 description Trunk to pac-inet-as1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
 switchport access vlan 30
!
interface GigabitEthernet1/0/6
 switchport access vlan 32
!
interface GigabitEthernet1/0/7
 switchport access vlan 36
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
 no switchport
 ip address 192.168.70.2 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan15
 description Inet Server Public
 ip address 192.168.15.2 255.255.255.0
!
interface Vlan28
 description Management VLAN
 ip address 192.168.28.121 255.255.255.0
!
interface Vlan30
 description Inet Client
 ip address 192.168.30.1 255.255.255.0
!
interface Vlan32
 description Inet Public Client
 ip address 192.168.32.1 255.255.255.0
!
interface Vlan34
 description Inet Direct Access
 ip address 192.168.34.1 255.255.255.0
!
interface Vlan36
 description Wi-Fi Management
 ip address 192.168.36.1 255.255.255.0
!
interface Vlan38
 description Wi-Fi Client
 ip address 192.168.46.1 255.255.248.0
!
interface Vlan71
 description Spectrum Public
 ip address 192.168.71.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.70.1
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
line con 0
line vty 0 4
 password xxxxxx
 login
line vty 5 15
 password xxxxxx
 login

Full Layer 2 Switch:

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname pac-inet-as1
!
no aaa new-model
switch 2 provision ws-c3750g-48ts
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet2/0/1
 switchport access vlan 30
 switchport mode access
!
interface GigabitEthernet2/0/2
!
interface GigabitEthernet2/0/3
!
interface GigabitEthernet2/0/4
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface GigabitEthernet2/0/13
!
interface GigabitEthernet2/0/14
!
interface GigabitEthernet2/0/15
!
interface GigabitEthernet2/0/16
!
interface GigabitEthernet2/0/17
!
interface GigabitEthernet2/0/18
!
interface GigabitEthernet2/0/19
!
interface GigabitEthernet2/0/20
!
interface GigabitEthernet2/0/21
!
interface GigabitEthernet2/0/22
!
interface GigabitEthernet2/0/23
!
interface GigabitEthernet2/0/24
!
interface GigabitEthernet2/0/25
!
interface GigabitEthernet2/0/26
!
interface GigabitEthernet2/0/27
!
interface GigabitEthernet2/0/28
!
interface GigabitEthernet2/0/29
!
interface GigabitEthernet2/0/30
!
interface GigabitEthernet2/0/31
!
interface GigabitEthernet2/0/32
!
interface GigabitEthernet2/0/33
!
interface GigabitEthernet2/0/34
!
interface GigabitEthernet2/0/35
!
interface GigabitEthernet2/0/36
!
interface GigabitEthernet2/0/37
!
interface GigabitEthernet2/0/38
!
interface GigabitEthernet2/0/39
!
interface GigabitEthernet2/0/40
!
interface GigabitEthernet2/0/41
!
interface GigabitEthernet2/0/42
!
interface GigabitEthernet2/0/43
!
interface GigabitEthernet2/0/44
!
interface GigabitEthernet2/0/45
!
interface GigabitEthernet2/0/46
!
interface GigabitEthernet2/0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/48
!
interface GigabitEthernet2/0/49
!
interface GigabitEthernet2/0/50
!
interface GigabitEthernet2/0/51
!
interface GigabitEthernet2/0/52
!
interface Vlan1
 no ip address
!
interface Vlan28
 ip address 192.168.28.141 255.255.255.0
!
ip classless
ip http server
!
!
control-plane
!
line con 0
 password xxxxxxx
 login
line vty 0 4
 password xxxxxxx
 login
line vty 5 15
 no login
!

Layer 3 Switch Spanning Tree on Vlan 28:

VLAN0028
  Spanning tree enabled protocol ieee
  Root ID    Priority    32796
             Address     0019.2f19.c800
             Cost        4
             Port        3 (GigabitEthernet1/0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32796  (priority 32768 sys-id-ext 28)
             Address     0027.0dc6.5480
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/3             Root FWD 4         128.3    P2p

Layer 2 Switch had no spanning tree on Vlan 28:

Spanning tree instance(s) for vlan 28 does not exist.
9
  • Edit your question to include the full switch configurations, then we can determine where you are going wrong.
    – Ron Maupin
    Apr 22, 2017 at 19:07
  • Okay, I added all pertinent config. Really, I don't know where to start.
    – dthree
    Apr 22, 2017 at 19:17
  • You need to add the full configuration. There are other configurations that affect this. What you have there looks OK, but you are missing important configurations.
    – Ron Maupin
    Apr 22, 2017 at 19:18
  • Have you defined the VLAN on both switches?
    – Ron Trunk
    Apr 22, 2017 at 19:18
  • I really need to see the layer-2 switch configuration. That is probably what is wrong.
    – Ron Maupin
    Apr 22, 2017 at 19:22

3 Answers 3

2

First, in your layer-3 switch, the default route is to an address for which you have no network. That isn't going to work.

Next, I don't see a default gateway for your layer-2 switch. It is like any other host on VLAN 28, and it needs a default gateway to be able to get to other network. That should be the layer-3 switch VLAN 28 address: 192.168.28.121.

You should also set up the password, and login on all the VTY lines, and have transport input telnet on the VTY lines.

When you telnet into one switch, you should be able to run telnet on that switch to get to the other switch.

1
  • I still can't ping 192.168.28.121 from the access switch. Should I be able to?
    – dthree
    Apr 22, 2017 at 21:14
2

One way to do this is to create a VLAN for management (you don't have to have a separate VLAN, but it's a good practive), and assign IP addresses to the VLAN interfaces. Make sure they are in the same IP subnet. Then, make sure your trunk port on both switches allows that VLAN. You don't need an access port on that VLAN -- just the trunk port will do.

Edit: You need to create the VLAN on the layer 2 switch. From the config prompt, type:

vlan 28
name Management
end

Then you should see the spanning tree instance on the witch

4
  • Okay got it. I added this above, please let me know what I'm missing.
    – dthree
    Apr 22, 2017 at 19:17
  • Run"show spanning-tree vlan 28" on both switches and post the results.
    – Ron Trunk
    Apr 23, 2017 at 13:26
  • Okay, updated that. Still stumped here...
    – dthree
    Apr 23, 2017 at 20:01
  • @dthree I edited my answer based on your post
    – Ron Trunk
    Apr 23, 2017 at 20:40
0

To accomplish your requirement that all the access switches and coreswitches to talk to each other in setup

Create addition management Vlan SVi in core switch . As example below .

Coreswitch(config)#interface Vlan 80

Coreswitch(config)#ip address 10.234.8.1 255.255.255.0

Coreswitch(config)#no shutdown

And assign this subnet IPaddress in access switch as below

Access(switch)#interface Vlan 80

Access(switch)ip address 10 .234.8.2 255.255.255.0

Access(switch)no shutdown

And Configured trunk port between Core and Access Switch

Now try to access core and access switch vise versa by management Vlan 80 ip address . By telnet or ssh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.