2

enter image description here

We have above network and here is the cisco trunk configuration.

Nexus 5548

 interface Ethernet1/9
  description F5-10G-Link
  switchport mode trunk
  switchport trunk allowed vlan 201

Cisco 3850 (non-root switch)

interface Port-channel20
 description F5-2G-Etherchannel trunk
 switchport trunk allowed vlan 201
 switchport mode trunk
end

interface GigabitEthernet1/0/45
 description F5-1G-a
 switchport trunk allowed vlan 201
 switchport mode trunk
 channel-protocol lacp
 channel-group 20 mode active
end

!
interface GigabitEthernet1/0/46
 description F5-1G-b
 switchport trunk allowed vlan 201
 switchport mode trunk
 channel-protocol lacp
 channel-group 20 mode active
end

links are up but if i check in STP configuration on cisco my 10G link is in blocking mode and 2G link is forwarding mode, as per STP cost calculation 10G link should be in forwarding because it has total cost to reach root is 4 and 2G link total cost to root is 5 right?

Even i tried to increase spanning-tree cost of 2G link but it didn't work still that link is in FWD mode.

SW2#sh spanning-tree int po20

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0201            Desg FWD 3         128.2046 P2p      

Nexus#sh spanning-tree int e1/9

Vlan             Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
VLAN0201         Altn BLK 2         128.137  P2p

If i am trying to shutdown 2G trunk then on Nexus switch i am seeing following spanning-tree status which is weird

Nexus# sh spanning-tree int e1/9

Vlan             Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
VLAN0201         Desg BKN*2         128.137  P2p *LOOP_Inc

and this interface never come into forwarding state.

what i am doing wrong here? is my cisco config is wrong on trunk?

EDIT

In f5 side we have default STP setting which is "Passthrough", Should i change it to RSTP?

  • Are you running CST or MST with the Big F5? PVST+ or Rapid-PVST+ is a Cisco propriety version of STP. – Ron Maupin Apr 26 '17 at 23:06
  • We are running spanning-tree mode rapid-pvst – Satish Apr 26 '17 at 23:12
  • The Big F5 needs an industry standard STP version. You are not allowing VLAN 1 on the trunks, and that is where the industry STP will send the BPDUs. – Ron Maupin Apr 26 '17 at 23:13
  • We have other F5 but not on these switch they are on different switch and they have no VLAN 1 in trunk configured and they are working so that is strange.. – Satish Apr 26 '17 at 23:22
  • If it's not sending BPDU the how my link go in FWD and BLK mode ? How STP making 10G in BLK if doesn't passing BPDU – Satish Apr 27 '17 at 0:26
2

If your F5 is in passthrough mode, that means it is transparent to BPDUs -- The C3850 and Nexus switch see each other as directly connected STP neighbors. So it makes sense that you can't block the 2G link. To the switches, the 10G and 2G links are the same link.

You should adjust the cost on the link between the two C3850 switches so that that one is blocking.

Cisco rapid-pvst and RSTP (802.1w) are not compatible, so you should not configure RSTP on the F5.

| improve this answer | |
  • What?? Why I should adjust cost between to c3850 trunk? It's in production also. Passthrough means that device is just dump and not doing anything right? If you see my question, why 2G link is fwd stat and 10G is in BLK ? And if I kill 2G link it's not getting failover to 10g link. – Satish Apr 27 '17 at 13:03
  • This is the post I found close to my issue devcentral.f5.com/questions/link-redundancy-on-cisco-switches – Satish Apr 27 '17 at 13:16
  • My STP failover putting 10G in loop guard mode and never recover, you can see in output in my question. – Satish Apr 27 '17 at 13:18
  • One more similar issue but unanswered supportforums.cisco.com/discussion/11594246/… – Satish Apr 27 '17 at 13:23
  • 1
    Pvstp is Cisco proprietary. Mstp is a standard – Ron Trunk Apr 28 '17 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.