2

We are having trouble when test the VPN remote-access with the above error. It returned domain name successfully when we run nslookup "router_IP" in window CMD but it keeps prompting the error window when we connected via Cisco Any Connect 3.1. We have Router cisco 3925, iOS Version 15.1(1)T1. Please help.

Updated1: Router's config

aaa new-model  
aaa authentication login AuthenList local  
aaa authorization network vpn-group local  
username vpn1 secret 5 xxxx  

crypto isakmp policy 10  
 encr 3des  
 hash md5  
 authentication pre-share  
 group 2  

ip local pool remote-pool 10.223.131.35 10.223.131.50  

crypto isakmp client configuration group cisco  
 key xxxx  
 pool remote-pool  

crypto ipsec transform-set set1 esp-3des esp-md5-hmac  
crypto dynamic-map map1 10  
 set transform-set set1  
 reverse-route  

crypto map map1 client authentication list AuthenList  
crypto map map1 isakmp authorization list vpn-group  
crypto map map1 client configuration address respond  
crypto map map1 10 ipsec-isakmp dynamic map1  


interface GigabitEthernet0/1  
 ip address A.B.C.D xxxx  
 ip nat outside  
 ip virtual-reassembly  
 duplex auto  
 speed auto  
 crypto map map1  

The error:

The VPN connection failed due to unsuccessful domain name resolution

when I entered the domain name of router's interface g0/1 from nslookup (server 8.8.8.8)**

Updated2:

I could do forward nslookup but reverse lookup (domain name -> IP) returns failed. Is it a problem?

Update3:
In router's config:
ip name-server 8.8.8.8

  • You need to edit your question to include the router configuration. Also, include any logs and exact error messages. – Ron Maupin May 1 '17 at 15:51
  • @RonMaupin I updated it, please help – SpiderlinK May 1 '17 at 16:10
  • If there is no DNS name to address resolution, then you can't use the DNS name. You could use the IP address. – Ron Maupin May 1 '17 at 16:40
  • Hi, when I entered the IP address, it said that "Could not connect to server. Please verify Internet connectivity and server address". I'm pretty sure that Internet and IP address are OK, correct. – SpiderlinK May 1 '17 at 16:57
  • Did you configure DNS resolution on the router? – Ron Trunk May 1 '17 at 17:07
1

Seems that configuration of SSL VPN is not completed or incorrect (according to provided part of config). Try to read this guide and do a walk thru steps in it.

  • I got this error when followed your instructions. Do you know why? R2#copy tftp: flash:/webvpn/ Address or name of remote host []? 192.168.85.128 Source filename []? anyconnect-win-3.1.03103-k9.pkg Destination filename [/webvpn/anyconnect-win-3.1.03103-k9.pkg]? Accessing tftp://192.168.85.128/anyconnect-win-3.1.03103-k9.pkg... Loading anyconnect-win-3.1.03103-k9.pkg from 192.168.85.128 (via FastEthernet0/0): ! %Error opening slot0:/webvpn/anyconnect-win-3.1.03103-k9.pkg (No such device) – SpiderlinK Jun 7 '17 at 2:14
  • The same error with copy tftp: flash: %Error opening slot0:/webvpn/anyconnect-win-3.1.03103-k9.pkg (No such device) – SpiderlinK Jun 7 '17 at 2:16
  • @bim in enable mode execute dir all-filesystems and look for what file storages you have. On my ASA5515x there's disk0: device. – Andrey Prokhorov Jun 7 '17 at 6:48
  • @ Andrey Hi, this is a test env on GNS3, I test it before go on real device but when I hit above command, it only shows system, tmpsys and nvram – SpiderlinK Jun 8 '17 at 1:20
  • @bim with what virtualization you're running Cisco 3925 in GNS3? – Andrey Prokhorov Jun 8 '17 at 12:22
0

I received this message today while working at home on my FDA laptop. "The VPN connection failed due to unsuccessful domain name resolution". When I called FDA's helpdesk I found that we connect to a different VPN from Cisco AnyConnect Secure Mobility Client. It's called VPN-Preferred. When I chose that instead of "Remote Connection" I connected to VPN-Preferred in a snap. No more issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.