1

I'm beginner, and I have problems with BGP. I don't really understand why it doesn't work correctly.

This is my topology:

![topology

detail

I need to ping from R8 to R10.

This is the configuration of R8:

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R8
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 ip address 199.168.1.9 255.255.255.252
 serial restart-delay 0
!
interface Serial1/2
 ip address 50.1.0.1 255.0.0.0
 serial restart-delay 0
!
interface Serial1/3
 ip address 199.168.1.2 255.255.255.252
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet4/0
 no ip address
 shutdown
 duplex half
!
interface Serial5/0
 ip address 199.168.1.22 255.255.255.252
 serial restart-delay 0
!
interface Serial5/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 redistribute bgp 100 metric 100 100 100 100 100
 network 199.168.1.0 0.0.0.3
 network 199.168.1.8 0.0.0.3
 network 199.168.1.20 0.0.0.3
 auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 50.1.0.0 mask 255.255.255.0
 neighbor 50.1.0.2 remote-as 200
 neighbor 50.1.0.2 next-hop-self
 neighbor 199.168.1.1 remote-as 100
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
no cdp log mismatch duplex
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
 escape-character 3
line vty 5 15
 login
 escape-character 3
!
!
end

This one is the configuration of R10:

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R10
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 ip address 50.1.0.2 255.0.0.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 195.16.1.10 255.255.255.252
 serial restart-delay 0
!
interface Serial1/2
 ip address 195.16.1.22 255.255.255.252
 serial restart-delay 0
!
interface Serial1/3
 ip address 195.16.1.13 255.255.255.252
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet4/0
 no ip address
 shutdown
 duplex half
!
router eigrp 2
 redistribute bgp 200 metric 100 100 100 100 100
 network 195.16.1.8 0.0.0.3
 network 195.16.1.12 0.0.0.3
 network 195.16.1.20 0.0.0.3
 auto-summary
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 50.1.0.0 mask 255.255.255.0
 redistribute eigrp 2
 neighbor 50.1.0.1 remote-as 100
 neighbor 50.1.0.1 next-hop-self
 neighbor 195.16.1.14 remote-as 200
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
no cdp log mismatch duplex
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

When I run the command, show ip bgp in R8, I have:

R8#show ip bgp
BGP table version is 7, local router ID is 199.168.1.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i195.16.1.0/30    20.1.0.2                 0    100      0 200 ?
*>                  50.1.0.2           2681856             0 200 ?
* i195.16.1.4/30    20.1.0.2           2681856    100      0 200 ?
*>                  50.1.0.2           2681856             0 200 ?
* i195.16.1.8/30    20.1.0.2           2681856    100      0 200 ?
*>                  50.1.0.2                 0             0 200 ?
* i195.16.1.12/30   20.1.0.2                 0    100      0 200 ?
*>                  50.1.0.2                 0             0 200 ?
* i195.16.1.16/30   20.1.0.2                 0    100      0 200 ?
*>                  50.1.0.2           2681856             0 200 ?
* i195.16.1.20/30   20.1.0.2           2681856    100      0 200 ?
*>                  50.1.0.2                 0             0 200 ?

Please help me.

  • You need edit your question to include the full configurations of the two routers. There are other configurations that may play a part in this. – Ron Maupin May 12 '17 at 15:30
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Feb 19 '18 at 4:03
  • I didn't configure the OSPF correctly, that's why I had some issues. – Lilia Mar 19 '18 at 16:08
  • Then you can (should) add an answer and accept it. Otherwise the question will keep popping up forever, looking for an answer. – Ron Maupin Mar 19 '18 at 16:12
3

You have not set the clock rate on the DCE side of the connection. The command is clock rate <rate>. See Cisco IOS Interface and Hardware Component Command Reference.

Another problem is that you have a network statement that does not match the actual network. Your interfaces are in the 50.1.0.0/8 network, but your BGP network statement is for the 50.1.0.0/24 network. BGP will only advertise the exact network that exists in the routing table, and if the network statement doesn't match, it will not be advertised.

You are also creating a routing loop with your redistribution. eBGP has a lower AD than EIGRP so any routes received from both will prefer eBGP. You should be careful about redistribution. You can use tags and communities to prevent receiving routes originating in your AS from being received from a different AS, or you can drop the redistribution in BGP and only use network statements.

0

The problem was in OSPF, all the ping that was realised in the area 200 was with the BGP. I should verify the ping in every area first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.